cancel
Showing results for 
Search instead for 
Did you mean: 

Failed to parse plugin descriptor for com.smartbear:ready-api-soapui-pro:3.3.0

SOLVED
Highlighted
New Contributor

Failed to parse plugin descriptor for com.smartbear:ready-api-soapui-pro:3.3.0

Error while building Ready API project using Maven POM

 

Failed to parse plugin descriptor for com.smartbear:ready-api-soapui-pro:3.3.0 (/apps/jenkins-agent/.m2/repository/com/smartbear/ready-api-soapui-pro/3.3.0/ready-api-soapui-pro-3.3.0.jar): No plugin descriptor found at META-INF/maven/plugin.xml

 

POM:

 

 

<?xml version="1.0" encoding="UTF-8"?>
<project
xmlns="http://maven.apache.org/POM/4.0.0"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
<modelVersion>4.0.0</modelVersion>
<groupId>com</groupId>
<artifactId>cm</artifactId>
<packaging>maven-plugin</packaging>
<version>1.0-SNAPSHOT</version>
<name>me</name>
<url>http://maven.apache.org</url>
<properties>
<aspectj.version>1.8.10</aspectj.version>
</properties>
<pluginRepositories>
<pluginRepository>
<id>SmartBearPluginRepository</id>
<url>http://www.soapui.org/repository/maven2/</url>
</pluginRepository>
</pluginRepositories>
<build>
<plugins>
<plugin>
<groupId>com.smartbear</groupId>
<artifactId>ready-api-soapui-pro</artifactId>
<version>3.3.0</version>
<dependencies>
<!-- dependency><groupId>mysql</groupId><artifactId>mysql-connector-java</artifactId><version>5.1.6</version></dependency-->
<dependency>
<groupId>mysql</groupId>
<artifactId>mysql-connector-java</artifactId>
<version>3.3.05</version>
<scope>runtime</scope>
</dependency>
<!-- <dependency>
<groupId>com.smartbear</groupId>
<artifactId>ready-api-core</artifactId>
<version>3.3.0</version>
</dependency>
<dependency>
<groupId>com.smartbear</groupId>
<artifactId>ready-api-soapui</artifactId>
<version>3.3.0</version>
</dependency>
<dependency>
<groupId>com.smartbear</groupId>
<artifactId>ready-api-runners</artifactId>
<version>3.3.0</version>
</dependency>
<dependency>
<groupId>org.apache.maven</groupId>
<artifactId>maven-plugin-api</artifactId>
<version>2.0</version>
</dependency> -->
<dependency>
<groupId>com.smartbear</groupId>
<artifactId>ready-api-maven-plugin</artifactId>
<version>3.3.0</version>
<type>maven-plugin</type>
<!-- </dependency>
<dependency>
<groupId>com.smartbear.soapui</groupId>
<artifactId>soapui-pro-maven-plugin</artifactId>
<version>3.3.0</version> -->

<exclusions>
<!--
These are mainly GUI artifacts not needed in the headless test runner
-->
<!--
TODO We might also want to remove: fife:rsyntaxtextarea.
It's included in prior versions (< 4.5.2) though
-->
<!-- JGoodies -->
<exclusion>
<groupId>javafx</groupId>
<artifactId>jfxrt</artifactId>
</exclusion>
<exclusion>
<groupId>com.jgoodies</groupId>
<artifactId>forms</artifactId>
</exclusion>
<exclusion>
<groupId>com.jgoodies</groupId>
<artifactId>looks</artifactId>
</exclusion>
<exclusion>
<groupId>com.jgoodies</groupId>
<artifactId>binding</artifactId>
</exclusion>
</exclusions>
</dependency>
<!-- https://mvnrepository.com/artifact/org.codehaus.groovy/groovy-all -->
<dependency>
<groupId>org.codehaus.groovy</groupId>
<artifactId>groovy-all</artifactId>
<version>2.4.17</version>
</dependency>
<!-- https://mvnrepository.com/artifact/org.ini4j/ini4j -->
<dependency>
<groupId>org.codehaus.groovy</groupId>
<artifactId>groovy-all</artifactId>
<version>2.4.17</version>
</dependency>
<!-- https://mvnrepository.com/artifact/org.apache.poi/poi -->
<dependency>
<groupId>org.apache.poi</groupId>
<artifactId>poi</artifactId>
<version>3.12</version>
</dependency>
<!-- https://mvnrepository.com/artifact/org.apache.poi/poi-ooxml -->
<dependency>
<groupId>org.apache.poi</groupId>
<artifactId>poi-ooxml</artifactId>
<version>3.12</version>
</dependency>
<!-- https://mvnrepository.com/artifact/org.apache.poi/poi-ooxml-schemas -->
<dependency>
<groupId>org.apache.poi</groupId>
<artifactId>poi-ooxml-schemas</artifactId>
<version>3.12</version>
</dependency>
<dependency>
<groupId>org.ini4j</groupId>
<artifactId>ini4j</artifactId>
<version>0.5.4</version>
</dependency>
<dependency>
<groupId>com.oracle.ojdbc</groupId>
<artifactId>ojdbc8</artifactId>
<version>19.3.0.0</version>
</dependency>
<!-- https://mvnrepository.com/artifact/net.sf.jasperreports/jasperreports -->
<!-- dependency><groupId>com.oracle</groupId><artifactId>ojdbc</artifactId><version>8</version><scope>system</scope><systemPath>${basedir}/bin/ext/ojdbc8.jar</systemPath></dependency-->
<!-- dependency><groupId>com.smartbear</groupId><artifactId>ready-api</artifactId><version>3.1.0</version><scope>system</scope><systemPath>${project.basedir}/lib/ready-api-maven-plugin-3.1.0.jar</systemPath></dependency-->
<!-- https://mvnrepository.com/artifact/net.sf.jasperreports/jasperreports -->
<dependency>
<groupId>net.sf.jasperreports</groupId>
<artifactId>jasperreports</artifactId>
<version>6.4.0</version>
</dependency>
<dependency>
<groupId>org.reflections</groupId>
<artifactId>reflections</artifactId>
<version>0.9.10</version>
</dependency>
<dependency>
<groupId>com.jgoodies</groupId>
<artifactId>forms</artifactId>
<version>1.0.7</version>
</dependency>
<dependency>
<groupId>io.qameta.allure</groupId>
<artifactId>allure-junit4</artifactId>
<version>2.13.5</version>
</dependency>
<!-- <dependency><groupId>io.qameta.allure</groupId><artifactId>allure-maven</artifactId><version>2.10.0</version></dependency> -->
</dependencies>
<configuration>
<settingsFile>${basedir}/soapui-settings.xml</settingsFile>
<junitReport>true</junitReport>
<printReport>true</printReport>
<coverage>${basedir}/reports</coverage>
<testSuite>${SuiteName}</testSuite>
<soapuiProperties>
<property>
<name>soapui.ext.libraries</name>
<value>${basedir}/bin/ext</value>
</property>
<property>
<name>soapui.home</name>
<value>${basedir}/bin</value>
</property>
</soapuiProperties>
</configuration>
<executions>
<execution>
<phase>test</phase>
<goals>
<goal>test</goal>
</goals>
<configuration>
<projectFile>${project.basedir}/SoapuiProject/CAMS/CAMS-API-Services-soapui-project.xml</projectFile>
<!-- exportAll>true</exportAll-->
<!-- reportFormat>HTML</reportFormat-->
<!-- printReport>true</printReport-->
<!-- junitReport>true</junitReport-->
<!--coverage>true</coverage-->
<!--exportAll>true</exportAll-->
<reportFormat>PDF</reportFormat>
<reportType>"Project Report"</reportType>
<testFailIgnore>true</testFailIgnore>
<reports>${basedir}/Report</reports>
<reportName>"Project Report"</reportName>
<!-- outputFolder>${basedir}/target/surefire-reports</outputFolder-->
<outputFolder>${basedir}/SoapuiProject/CAMS/ReqRespPair</outputFolder>
<projectProperties>
<value>message=Hello World!</value>
</projectProperties>
</configuration>
</execution>
</executions>
</plugin>
<plugin>
<groupId>org.apache.maven.plugins</groupId>
<artifactId>maven-surefire-plugin</artifactId>
<version>2.16</version>
</plugin>
</plugins>
</build>
<reporting>
<plugins>
<plugin>
<groupId>org.apache.maven.plugins</groupId>
<artifactId>maven-surefire-report-plugin</artifactId>
<version>3.0.0-M4</version>
<!-- ${shadedVersion}, but resolved due to https://issues.apache.org/jira/browse/MRELEASE-799 -->
<reportSets>
<reportSet>
<reports>
<report>report-only</report>
</reports>
</reportSet>
</reportSets>
<configuration>
<outputName>Automation-Execution Report</outputName>
<outputDirectory>${basedir}/report</outputDirectory>
<reportsDirectory>${basedir}/report/soapui</reportsDirectory>
</configuration>
</plugin>
<plugin>
<groupId>org.apache.maven.plugins</groupId>
<artifactId>maven-site-plugin</artifactId>
<version>3.7.1</version>
<configuration>
<outputDirectory>${basedir}/target/surefire-reports</outputDirectory>
</configuration>
</plugin>
</plugins>
</reporting>
</project>

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
New Contributor

Re: Failed to parse plugin descriptor for com.smartbear:ready-api-soapui-pro:3.3.0

Worked with ReadyAPI3.0.0

View solution in original post

6 REPLIES 6
Highlighted
Community Manager

Re: Failed to parse plugin descriptor for com.smartbear:ready-api-soapui-pro:3.3.0

Anyone faced a similar issue? 

@HimanshuTayal @nmrao @richie @aaronpliu 


Sonya Mihaljova
Community and Education Specialist

Learn SmartBear products in a fun and easy way and prove your knowledge!
>>Participate in the TechCorner Challenge today
Community Hero

Re: Failed to parse plugin descriptor for com.smartbear:ready-api-soapui-pro:3.3.0

I dont have the tool, so no ideas.

However, below can be checked.
1. what maven version is used? if not using maven 3.x, the worth giving a try. You can check using command "mvn -version". Hope you are using JDK 8 or more.
Also refer documentation if not already
https://support.smartbear.com/readyapi/docs/configure/plugins/dev/tools/maven.html?sbsearch=maven%20...
2. try removing below directory:
/apps/jenkins-agent/.m2/repository/com/smartbear/ready-api-soapui-pro/3.3.0


Regards,
Rao.
Highlighted
Community Manager

Re: Failed to parse plugin descriptor for com.smartbear:ready-api-soapui-pro:3.3.0

Thank you for your advice Rao!

 

@madhankumarbs did you have a chance to apply the advice given? 


Sonya Mihaljova
Community and Education Specialist

Learn SmartBear products in a fun and easy way and prove your knowledge!
>>Participate in the TechCorner Challenge today
Highlighted
New Contributor

Re: Failed to parse plugin descriptor for com.smartbear:ready-api-soapui-pro:3.3.0

org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute goal com.smartbear:ready-api-maven-plugin:3.2.0:test (default) on project kpifoff: Execution default of goal com.smartbear:ready-api-maven-plugin:3.2.0:test failed: Unable to load the mojo 'test' in the plugin 'com.smartbear:ready-api-maven-plugin:3.2.0' due to an API incompatibility: org.codehaus.plexus.component.repository.exception.ComponentLookupException: com/eviware/soapui/maven2/TestMojo has been compiled by a more recent version of the Java Runtime (class file version 55.0), this version of the Java Runtime only recognizes class file versions up to 52.0

 I'm still facing the issue.. I tried it by downgrading the ReadyAPI versions too

Highlighted
New Contributor

Re: Failed to parse plugin descriptor for com.smartbear:ready-api-soapui-pro:3.3.0

Worked with ReadyAPI3.0.0

View solution in original post

Highlighted
Community Manager

Re: Failed to parse plugin descriptor for com.smartbear:ready-api-soapui-pro:3.3.0

This is just awesome, thank you or sharing @madhankumarbs !


Sonya Mihaljova
Community and Education Specialist

Learn SmartBear products in a fun and easy way and prove your knowledge!
>>Participate in the TechCorner Challenge today
New Here?
Join us and watch the welcome video:
Announcements
TechCorner Leaderboard
Want a fun and easy way to learn ReadyAPI and show off your skills? Try solving weekly TechCorner challenges and get into the Leaderboard!


Challenge Status

Compare an expected JSON value and actual response in Events

Participate!

Fetch value/data from JSON response using Groovy Script

See replies!

Filtering data retrieved from a DataSource

See replies!

Get data from Petstore and add it to Excel sheets

Participate!
Top Kudoed Authors