cancel
Showing results for 
Search instead for 
Did you mean: 

Auth Manager->Profile->Automation Scripts in 2.6 errors out

Highlighted
New Contributor

Auth Manager->Profile->Automation Scripts in 2.6 errors out

I have a lot of authentication profiles that use the automation tab to retreive tokens from a website.  However, when upgrading from 2.5 to 2.6 of ReadyAPI my tests constantly fail this step at random and hang the entire test run.

 

Here is some example javascript I use to get my token.  It has worked 100% of the time without fail in 2.5 and continues to work when even now with 2.5.  However, with 2.6 the same exact code around 50% of the time results in a hang or an error page saying they can't display the page.

 

document.getElementsByName("username")[0].value = 'someusername';
document.getElementsByName("password")[0].value = 'somepassword';
document.getElementsByName("login")[0].click();

 

Anyone else having similar issues?  We really wanted to use the new git functionality but will have to stay at 2.5 until this is resolved.

3 REPLIES 3
Community Manager

Re: Auth Manager->Profile->Automation Scripts in 2.6 errors out

Hi Quinny1187,

 

If you can reproduce this issue, I recommend that you submit a support ticket to our Customer Care team. They will need to investigate this behavior with the latest ReadyAPI version. You can submit a support ticket here:

http://support.smartbear.com/message/?prod=ReadyAPI

---------
Tanya Gorbunova
SmartBear Community Manager

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others.↓↓↓↓↓
Occasional Contributor

Re: Auth Manager->Profile->Automation Scripts in 2.6 errors out

We have noticed the same issue with "Basic" Authentication as well as  Auth Manager profiles with the 2.6.0 Release. Using the 2.5.0 release work we do not have connectivity issues, but with 2.6.0, we have connectivity / timeout issues.

Community Manager

Re: Auth Manager->Profile->Automation Scripts in 2.6 errors out

Hi @sdeevers,

 

In this case, it sounds like an issue in ReadyAPI 2.6. Have you reported it to the Support Team? Any news from them?

 

Also, it's worth checking if the latest maintenance build has the same issue. You can download this build here:

https://support.smartbear.com/downloads/readyapi/maintenance

---------
Tanya Gorbunova
SmartBear Community Manager

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others.↓↓↓↓↓
New Here?
Join us and watch the welcome video:
Top Kudoed Authors