Ask a Question

web service process issue :

harivignesh27
Occasional Contributor

web service process issue :

Hi Smartbear Team,

 

Concept  : 

 

              While i am using a webservice in soap ui its returns proper response.but i did an action while running input xml in soap ui, based on its input a auto number will generated and saved in backend corresponding table.This concept working in WCF Test Client and WcfStorm tools when i execute in Soap ui this concept not working.

 

Process Issue : 

 

              My question is  why my concept not working in soap ui tool.Its returns proper response but autogenerated attribute value not saved in backend table.

 

             i did attached webservice input xml declaration for your kind reference.kindly consider it and give a solution for my problem.

 

Note : 

    

      Refer Img1.png : Based on Attribute_ID and Type_ID input, i will generate an auto generated number.

 

 

Thanks&reg,

harivignesh.t.g

  

6 REPLIES 6
nmrao
Community Hero

Re: web service process issue :

Looks your description either confusing or not clear what you mean by generating auto number (who does this) and also what is meant by saved in backend, you mean when request is sent to server, is not it saving into backend is responsibility of server? Can you reply with more clarity?


Regards,
Rao.
nmrao
Community Hero

Re: web service process issue :

By the way, you should redo the file upload in text format instead of xml as that does not appear be an xml and browser does not allow to open.


Regards,
Rao.
harivignesh27
Occasional Contributor

Re: web service process issue :

Hi Rao,

 

         Find the attachement it contains request and response values of  webservice.while i am run the webservice with input values, [refer request.txt] based on attribute_id and type_id  values a stored procedure executes at service run time and update some value in sql table.Using this webservices in wcf test client and wcfstorm tools working fine but in soap ui not working.This is my problem.

 

 

 

 

 

 

     

           

         

harivignesh27
Occasional Contributor

Re: web service process issue :

OOPs Text file attached with this post

nmrao
Community Hero

Re: web service process issue :

Do you think that the service is hit when the request is sent from SOAPUI? Do you confirm this from your application logs?


Regards,
Rao.
harivignesh27
Occasional Contributor

Re: web service process issue :

Hi Rao,

 

    Yep ,the service is hit when the request is sent from SOAPUI.But  based on attribute_id and type_id  values that stored procedure not executes.

cancel
Showing results for 
Search instead for 
Did you mean: