cancel
Showing results for 
Search instead for 
Did you mean: 

trim for values with spaces deletes the spaces

Contributor

trim for values with spaces deletes the spaces

i want to test the trim of spaces entered before and after the values (  password  ) to work correctly but when i save the projects and open them the next time soapui automatically deletes the spaces and i cant test correctly.

is there a possibility to disable this feature? or do i have to enter the values in a special way like escaped?

thanks
Christoph
4 REPLIES 4
Super Contributor

Re: trim for values with spaces deletes the spaces

Hi Chris,

is this in a standard XML request editor? Have you tried to turn off pretty-printing (Preferences\WSDL Settings)?

regards!

/Ole
eviware.com
Highlighted
Contributor

Re: trim for values with spaces deletes the spaces

Hi Ole,

i did a bit of investigation and it always happens when i have to do a refactor (which i had to do lately).
as far sa i could see it works when you just save the project and open it again as i had the pretty print turned off anyway.

Regards
Chris
Super Contributor

Re: trim for values with spaces deletes the spaces

Hi Chris,

thanks for following up, we'll check the refactor-code to see if this can be fixed..

regards,

/Ole
eviware.com
Contributor

Re: trim for values with spaces deletes the spaces

Hi Chris,

This is probably caused by a pretty print that is performed by the refactoring code. I am creating an option to disable the pretty print. This will be available in the next build. Please let us know if this solves your problem.

Regards,
/Lars
eviware.com
New Here?
Join us and watch the welcome video:
Watch the new Interview
Top Kudoed Authors