cancel
Showing results for 
Search instead for 
Did you mean: 

soapui-maven-plugin-5.4.0 is not working

SOLVED
Highlighted
Occasional Contributor

soapui-maven-plugin-5.4.0 is not working

I followed the instructions to add the pluginrepo and plugin, but when running the project I receive following error:

[ERROR] Failed to execute goal com.smartbear.soapui:soapui-maven-plugin:5.4.0:test (default-cli) on project soapuirunner: Execution default-cli of goal com.smartbear.soapui:soapui-maven-plugin:5.4.0:test failed: A required class was missing while executing com.smartbear.soapui:soapui-maven-plugin:5.4.0:test: com/jgoodies/forms/layout/CellConstraints

 

I have also tried to add different versions of this jgoodies-forms as a dependency, but without any success:

<dependency>
	<groupId>com.jgoodies</groupId>
	<artifactId>jgoodies-forms</artifactId>
	<version>1.9.0</version>
</dependency>

Can someone please help me to solve this issue?

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Occasional Contributor

Re: soapui-maven-plugin-5.4.0 is not working

Hello,

I have managed to solve the issue, I was adding the jgoodies-forms as a normal dependency instead of a plugin dependency.

 

Once adding it as a plugin dependency it works.

View solution in original post

4 REPLIES 4
Highlighted
Occasional Contributor

Re: soapui-maven-plugin-5.4.0 is not working

It looks to be coming from here:

 

Caused by: java.lang.NoClassDefFoundError: com/jgoodies/forms/layout/CellConstraints
	at com.eviware.soapui.impl.wsdl.teststeps.assertions.basic.SimpleContainsAssertion.<clinit>(SimpleContainsAssertion.java:73)
Highlighted
Community Manager

Re: soapui-maven-plugin-5.4.0 is not working

Hello Community! Can anyone help with this issue? Thanks in advance!


Sonya Mihaljova
Community and Education Specialist

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️
Highlighted
Occasional Contributor

Re: soapui-maven-plugin-5.4.0 is not working

Hello,

I have managed to solve the issue, I was adding the jgoodies-forms as a normal dependency instead of a plugin dependency.

 

Once adding it as a plugin dependency it works.

View solution in original post

Highlighted
Community Manager

Re: soapui-maven-plugin-5.4.0 is not working

Great news! Thanks for marking the answer as a solution.


Sonya Mihaljova
Community and Education Specialist

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️
New Here?
Join us and watch the welcome video:
Top Kudoed Authors