cancel
Showing results for 
Search instead for 
Did you mean: 

soapUI 3.0 crashes on Fedora 9

elife
Occasional Contributor

soapUI 3.0 crashes on Fedora 9

I have just dowload soapui3.0 on Fedora 9.But Soapui  closes after a short time later.Here the errors.
The program 'TuxPack GTK+' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadMatch (invalid parameter attributes)'.
  (Details: serial 5869 error_code 8 request_code 144 minor_code 4)
  (Note to programmers: normally, X errors are reported asynchronously;
  that is, you will receive the error a while after causing it.
  To debug your program, run it with the --sync command line
  option to change this behavior. You can then get a meaningful
  backtrace from your debugger if you break on the gdk_x_error() function.)


and I tried to enable JAVA_OPTS="$JAVA_OPTS -Dsoapui.jxbrowser.disable=true" .But nothing changed. Could anyone help me urgently? thanks
4 REPLIES 4

Re: soapUI 3.0 crashes on Fedora 9

Hello,

I'm running it on Ubuntu 8.10 on Java(TM) SE Runtime Environment (build 1.6.0_14-b08). But have to disable JxBrowser ( uncomment -Dsoapui.jxbrowser.disable=true ). Does it open browser in soapUI when you start it or you get message that it is disabled?

BTW. are you running binaries or installer? In case of installer add  -Dsoapui.jxbrowser.disable=true to the vmoptions file.

let me know how it goes,
robert


Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️
elife
Occasional Contributor

Re: soapUI 3.0 crashes on Fedora 9

Hi,

I enabled JAVA_OPTS="$JAVA_OPTS -Dsoapui.jxbrowser.disable=true" in the soapui.sh. I just running installer.
Where should be the vmoptions file?
SoapUI browser  can open  new soapui project page but when I  tried to add any wsdl ,the browser was closed with this errors.
Thanks for quick reply ,

Elif

Re: soapUI 3.0 crashes on Fedora 9

Hello,

If you are using installer soapUI should be installed in user.dir/eviware/soapUI-3.0 or your prefered directory if you changed during installation. Anyway look for bin directory where are *.sh scripts are. There should be soapUI-3.0.vmoptions file. Add at the end -Dsoapui.jxbrowser.disable=true and try. Btw. if you are running from installer startup scripct will be soapUI-3.0 if you want to use options set in vmoptions file.

Does this helps,
robert


Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️
elife
Occasional Contributor

Re: soapUI 3.0 crashes on Fedora 9

Hi ,

I install the soapui from binary resource again.That solve my problem.I think there should be a  installer problem in  Fedora 9.
Thanks
New Here?
Join us and watch the welcome video:
Announcements
Top Kudoed Authors