Showing results for 
Search instead for 
Did you mean: zip file is empty

Occasional Contributor zip file is empty



I have a fresh installation of ReadyAPI 3.3.1.

Once I'm starting a groovy script I'm receiveing following error: zip file is empty zip file is empty
at$Source.zerror( ~[?:?]
at$Source.findEND( ~[?:?]
at$Source.initCEN( ~[?:?]
at$Source.<init>( ~[?:?]
at$Source.get( ~[?:?]



My question: what zip-file is the application looking for or/and how do I get rid of this error?


Thanks in advance.



Occasional Contributor

Thanks for the tip.

However, I don't know which zip-file ReadyAPI is trying to open. There is no zip-file in the installation directory.

Do you know?

Community Hero

Hey @WirtRo48,

Bit confused.
Your original post leads me to believe the error manifested when you tried running a groovy script, rather than just soapui startup, is that correct?

If the error occurs after executing a groovy step, then it follows the issue is within the groovyscript ir the file the script points to...could you publish your groovy so people can review it?

I cant remember if compile time errors occur only after selecting the groovystep or if its when the project is selected (for teardown scripts etc.)but if its being reported after soapui launches, id suggest identifying the relevant groovy by dropping each project then restarting to id which project is causing the issue. After that just follow it down by removing testsuites then testcases then teststeps until you find the problematic groovyscript. Dont forget there maybe startup/teardown, etc. scripts also.

Oh. Before doing anything create backups of your project files before you begin dropping them from the workspace. I work with readyapi!, but if soapui is the same then the projects get saved when you close the app, so you need to take backups before you start so you dont lose any work.

Once you find the problematic script you can then identify which .zip archive is the relevant one, so you can determine if it just needs repairing or if its being reported as empty due to a groovy issue.

Hope this helps!

Nice one

if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the Subject header field of the post to something more descriptive? This will help people when searching for problems. Ta
Occasional Contributor

Hey Rich.


Thanks for your answer. You are right - my description of the problem is confusing.

The error manifests directly during startup of ReadyAPI 3.3.1. My later execution of some groovy scripts does not have to seem anything to do with the problem.

When I start the application I receive the error - and therefore I do not know which zip file the application is trying to unpack.


Sorry for the confusion.


  • Add to Phrasebook
    • No word lists for English -> Swedish...
    • Create a new word list...
  • Copy
New Here?
Join us and watch the welcome video:
Top Kudoed Authors