cancel
Showing results for 
Search instead for 
Did you mean: 

Which version of POI bin files are compatible with SOAP UI 5.5 free version

SOLVED
Highlighted
Contributor

Which version of POI bin files are compatible with SOAP UI 5.5 free version

I am having Soap UI 5.5 version and trying to read an xlsx file. Previoulsy I had 4.6.4 and had no issues with the script.

now after upgrading to 5.5 version I am seeing error  "unable to resolve org.apache.poi.xssf.usermodel.XSSFSheet".

 

I have tried using poi bin files with version 4..1.2 , 4.1.1, 4.0.0 & 3.8 but still I am getting an error "unable to resolve org.apache.poi.xssf.usermodel.XSSFSheet"

 

Every time I use the new version of bin files made sure poi-ooxml .jar file is there and I re-open SoapUi to run the groovy script.

 I have copied belwo jar files  in to SoapUI/bin/ext

commons-collections .jar

poi-4.1.2.jar

poi-contrib-4.1.2.jar

poi-examples-4.1.2.jar

poi-excelant-4.1.2.jar

poi-ooxml-4.1.2.jar

poi-ooxml-schemas-4.1.2.jar

poi-scratchpad-4.1.2.jar

 

Any suggestions would help

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Contributor

Re: Which version of POI bin files are compatible with SOAP UI 5.5 free version

There were two versions of Soap UI installed which actually casued the issue, after installing the lower version the issue is fixed.

View solution in original post

8 REPLIES 8
Highlighted
Community Hero

Re: Which version of POI bin files are compatible with SOAP UI 5.5 free version

Have you restarted after copying files.


Regards,
Rao.
Highlighted
Contributor

Re: Which version of POI bin files are compatible with SOAP UI 5.5 free version

Yes I have restarted after Copying fiels, still getting the same error

Highlighted
Community Hero

Re: Which version of POI bin files are compatible with SOAP UI 5.5 free version

Ok. Do you know which jar file has this class?


Regards,
Rao.
Highlighted
Contributor

Re: Which version of POI bin files are compatible with SOAP UI 5.5 free version

As per the Poi wesite (https://poi.apache.org/components/index.html

" poi-ooxml" jar file is requried  to work on Xlsx files

Highlighted
Contributor

Re: Which version of POI bin files are compatible with SOAP UI 5.5 free version

There were two versions of Soap UI installed which actually casued the issue, after installing the lower version the issue is fixed.

View solution in original post

Highlighted
Community Leader

Re: Which version of POI bin files are compatible with SOAP UI 5.5 free version

@rajulapati : Which version have you used? I am also getting error in SoapUI while using XSSFWorkbook.

 


Click "Accept as Solution" if my answer has helped, and remember to give "kudos" 🙂

Thanks and Regards,
Himanshu Tayal
Highlighted
Contributor

Re: Which version of POI bin files are compatible with SOAP UI 5.5 free version

@HimanshuTayal  poi-4.1.2 worked for me

Highlighted
Community Leader

Re: Which version of POI bin files are compatible with SOAP UI 5.5 free version

Please help on my question 

 

https://community.smartbear.com/t5/SoapUI-Open-Source/Getting-error-while-importing-Excel-file-using...

 

 

If you have any input please let me know.


Click "Accept as Solution" if my answer has helped, and remember to give "kudos" 🙂

Thanks and Regards,
Himanshu Tayal
New Here?
Join us and watch the welcome video:
Top Kudoed Authors