cancel
Showing results for 
Search instead for 
Did you mean: 

WebUI not loading for SOAP MockService deployed as WAR

Highlighted
New Contributor

WebUI not loading for SOAP MockService deployed as WAR

I'm trying SoapUI for the first time to generate a (SOAP) mock service. Everything works locally when tested through SoapUI.

 

When I create a WAR with WebUI enabled and deploy to Tomcat 9, the mocking endpoint and ?wsdl endpoints work.

But when I try to load the WebUI, the page is empty.

 

What works:

[1] http://localhost:8080/soapuimocks/?wsdl

[2] SOAP requests sent to http://localhost:8080/soapuimocks/HelloService

 

What doesn't work:

http://localhost:8080/soapuimocks/  ==> 200 OK No content

http://localhost:8080/soapuimocks  ==> 200 OK  with following content

<html><head><title>SoapUI MockServices Log for project [Mocking]</title></head><frameset rows="40%,40%,*"><frame src="master"/><frame name="detail" src="detail"/><frame src="log"/></frameset></html>

See screen shot attached.

 

Please let me know if I'm doing something obviously wrong / need to provide more information to get to root cause.

 

Thanks in advance!

3 REPLIES 3
Highlighted
Community Hero

Re: WebUI not loading for SOAP MockService deployed as WAR

Where did you deploy service?
what makes you to think the urls (not working) are supposed to work?


Regards,
Rao.
Highlighted
New Contributor

Re: WebUI not loading for SOAP MockService deployed as WAR

Hello Rao,

 

Thank you for responding to my question.

 

>>Where did you deploy service?

The URL examples I gave are from a local deployment of the war file on a Tomcat 9 running (as a docker container) on my laptop. 

 

>>what makes you to think the urls (not working) are supposed to work?

The documentation below:

https://www.soapui.org/soap-mocking/deploying-mock-services-as-war-files.html

 

talks about a WebUI option which when enabled provides a console to view request/responses. Isn't the WebUI supposed to work on the URL I tried? If not, what is the URL for WebUI?

 

Regards,

Subu

 

Highlighted
New Contributor

Re: WebUI not loading for SOAP MockService deployed as WAR

I'm facing same issue.

For every requet using SOAPUI, getting response as 

<html>
<head>
<title>SoapUI MockServices Log for project [nb-workorder]</title>
</head>
<frameset rows="40%,40%,*">
<frame src="master"/>
<frame name="detail" src="detail"/>
<frame src="log"/>
</frameset>
</html>

 

Can I know how it is fixed

 

New Here?
Join us and watch the welcome video:
Top Kudoed Authors