cancel
Showing results for 
Search instead for 
Did you mean: 

User-Agent option issue ?

Highlighted
Occasional Contributor

User-Agent option issue ?

Hi,

 

 

I need to change the user-agent header field in my soap requests. But even if I set it in the preferences window, all my requests continue to use the HttpApache library standard's user-agent.

 

Here are the Raw data when I execute my request (I got 2 user-agent !):

POST https://xxx.xxx.xxx/Authentification HTTP/1.1
Accept-Encoding: gzip,deflate
User-Agent: SoapUI-metier
Content-Type: text/xml;charset=UTF-8
SOAPAction: ""
Host: xxx.xxx.xxx

Proxy-Connection: Keep-Alive
User-Agent: Apache-HttpClient/4.1.1 (java 1.5)

 

 

And here a wireshark dump of the headers :

CONNECT xxx.xxx.xxx:443 HTTP/1.1

Host: xxx.xxx.xxx

Proxy-Connection: Keep-Alive

User-Agent: Apache-HttpClient/4.1.1 (java 1.5)

 

Do I miss something in the configuration ?

 

Thanks.

Mathieu.

2 REPLIES 2
Community Hero

Re: User-Agent option issue ?

Some how I could see what I have as user-agent value in preferences, Tried on  SoapUI 4.x, 5.x

POST http://10.0.0.1:8080/eml/services/router HTTP/1.1
Connection: close
Accept-Encoding: gzip,deflate
User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/46.0.2490.80 Safari/537.36
Content-Type: text/xml;charset=UTF-8
SOAPAction: "RecordAction"
Authorization: Basic YWRtaW46YWRtaW4=
Content-Length: 6491
Host: 10.0.0.1:8080

Could not reproduce, somehow.

This is for soap request only.



Regards,
Rao.
Community Hero

Re: User-Agent option issue ?

New Here?
Join us and watch the welcome video:
Top Kudoed Authors