cancel
Showing results for 
Search instead for 
Did you mean: 

Unfortunately SOAPUI 5.2.1 removes 
 in SOAP requests. Does anybody has a solution.

SOLVED
tw
New Contributor

Unfortunately SOAPUI 5.2.1 removes 
 in SOAP requests. Does anybody has a solution.

I'm requesting a Webservice via SOAPUI  and I need to transfer  <hyp1:sFieldValue>Jahr&#13;2000</hyp1:sFieldValue>

Unfortunately SOAPUI 5.2.1 removes &#13; in the SOAP request. The snippet is part of a request, which is embedded in a Testcase with different Teststeps (SOAP-Requests). The encoding of the request is: <?xml version="1.0" erncoding "UTF-8"?>

 

Does anybody have a solution for this unwanted behavior removing &#13; in the request? I have to transmitt &#13;

(B.t.w. : Fiddler is working properly and does not clean &#13; , but Fiddler does not support Testcases)

 

Any help appreciated.

 

Thank you

TW

2 ACCEPTED SOLUTIONS

Accepted Solutions
nmrao
Community Hero

Re: Unfortunately SOAPUI 5.2.1 removes &#13; in SOAP requests. Does anybody has a solution.

Can you try it enclosing in 'cdata' as shown below?

<hyp1:sFieldValue><![CDATA[Jahr&#13;2000]]></hyp1:sFieldValue>


Regards,
Rao.

View solution in original post

nmrao
Community Hero

Re: Unfortunately SOAPUI 5.2.1 removes &#13; in SOAP requests. Does anybody has a solution.

Is there a confusion? There is a difference between what is suggested and tried or it must be a typo.

 

Below is the one that is suggested

<hyp1:sFieldValue><![CDATA[Jahr&#13;2012]]></hyp1:sFieldValue>

 

But you mentioned that you have tried

<hyp1:sFieldValue>![CDATA[Jahr&#13;2012]]</hyp1:sFieldValue>



Regards,
Rao.

View solution in original post

5 REPLIES 5
nmrao
Community Hero

Re: Unfortunately SOAPUI 5.2.1 removes &#13; in SOAP requests. Does anybody has a solution.

Can you try it enclosing in 'cdata' as shown below?

<hyp1:sFieldValue><![CDATA[Jahr&#13;2000]]></hyp1:sFieldValue>


Regards,
Rao.

View solution in original post

tw
New Contributor

Re: Unfortunately SOAPUI 5.2.1 removes &#13; in SOAP requests. Does anybody has a solution.

Hi,

 

thank you for your quick feedback. Unfortunately that is although not working as expected and delivers the same result.

 

I inspect my request again directing through Fiddler, to see what SOAPUI is sending in real to the SOAP-service.

Interesting:

If I send

- <hyp1:sFieldValue>Jahr&#13;2012</hyp1:sFieldValue>

or (following your hint)

- <hyp1:sFieldValue>![CDATA[Jahr&#13;2012]]</hyp1:sFieldValue>

 

For both SOAP requests SOAP sends

<hyp1:DCFieldValue><hyp1:sFieldName>DYNPART</hyp1:sFieldName><hyp1:sFieldValue>Jahr

2012</hyp1:sFieldValue></hyp1:DCFieldValue>

to the Webservice.

 

I guess, that SOAPUI itself interprets the "&#13;" as a carriage return, inject a "CR" between "Jahr" and "2012" will not transmit pure and unchanged "&#13;" to the webservice. When I switch to Fiddler HexView I can see a single hex "x0D"- char between "Jahr" and "2012"  

 

Why does SOAPUI change the well-formed xml-request ?? I would expect, that SOAPUI will transfer the well-formed xml-request to thewebservice and not manipulate it.

 

Any ideas?

 

Thank you

 

 

 

 

nmrao
Community Hero

Re: Unfortunately SOAPUI 5.2.1 removes &#13; in SOAP requests. Does anybody has a solution.

Is there a confusion? There is a difference between what is suggested and tried or it must be a typo.

 

Below is the one that is suggested

<hyp1:sFieldValue><![CDATA[Jahr&#13;2012]]></hyp1:sFieldValue>

 

But you mentioned that you have tried

<hyp1:sFieldValue>![CDATA[Jahr&#13;2012]]</hyp1:sFieldValue>



Regards,
Rao.

View solution in original post

tw
New Contributor

Re: Unfortunately SOAPUI 5.2.1 removes &#13; in SOAP requests. Does anybody has a solution.

Thank you !

 

for clarification. Indeed I missed two important parts. Now the contents "Jahr&#13;2012" will be transferred unchanged.

 

I see SOAPUI keeps all white spaces or blanks from its request editor windows.

 

Is there any possibility in preferences or some where else to clean up this white spaces or "minify" the request-xml-document to pure xml?

 

 

Thank you

Thomas

nmrao
Community Hero

Re: Unfortunately SOAPUI 5.2.1 removes &#13; in SOAP requests. Does anybody has a solution.

This is new question, please use new topic.


Regards,
Rao.
New Here?
Join us and watch the welcome video:
Top Kudoed Authors