Showing results for 
Search instead for 
Did you mean: 

Unexpected element: CDATA soapUI maven plugin

New Contributor

Unexpected element: CDATA soapUI maven plugin

I have tests for a REST API using json.

I use properties and property Transfer. When I run the property transfer inside soapUI (version 5.4.0), everything goes fine. However,  when I run them using soapui-maven-plugin:4.6.1, I got the following error:

Status: FAILED
Time Taken: 51
Size: 0
Timestamp: Mon Dec 31 09:47:23 GMT+01:00 2018
TestStep: Property Transfer
Error:com.eviware.soapui.impl.wsdl.teststeps.PropertyTransferException: error: Unexpected element: CDATA

----------------- Messages ------------------------------
Error performing transfer [zipCode] - error: Unexpected element: CDATA
zipCode transferred [[error: Unexpected element: CDATA]] from [Properties.zipCode] to [Address.Request]
------------ target path -------------

Any idea about what I'm doing wrong?


Notes: I'm not using any parameter, I'm just selecting "Media Type: application/json" and putting my json underneath.

New Contributor

Re: Unexpected element: CDATA soapUI maven plugin

Seems that the error was just comming from me not using the same version for SoapUI and SoapUI maven plugin. 

I just changed the soapui-maven-plugin version to match the one of SoapUI and it's working now.

2018 NEWS
Top Kudoed Authors