cancel
Showing results for 
Search instead for 
Did you mean: 

The sample project fails when run

Highlighted
Occasional Contributor

The sample project fails when run

Hi,
I am new to soapui2.0.2 Pro tool and am trying to run the sample project in the TestSuiteEditor. All my tests are failing as it says Connection rerfused.
Could any one help me run this TestSuite successfully.Thanks

  java.net.ConnectException: Connection refused: connect
  at java.net.PlainSocketImpl.socketConnect(Native Method)
  at java.net.PlainSocketImpl.doConnect(Unknown Source)
  at java.net.PlainSocketImpl.connectToAddress(Unknown Source)
  at java.net.PlainSocketImpl.connect(Unknown Source)
  at java.net.SocksSocketImpl.connect(Unknown Source)
  at java.net.Socket.connect(Unknown Source)
  at java.net.Socket.connect(Unknown Source)
  at java.net.Socket.(Unknown Source)
  at java.net.Socket.(Unknown Source)
  at org.apache.commons.httpclient.protocol.DefaultProtocolSocketFactory.createSocket(DefaultProtocolSocketFactory.java:79)
6 REPLIES 6
Highlighted
Super Contributor

Hi!

sounds like you haven't started the included MockService before running the tests.. Could that be the case?

regards!

/Ole
eviware.com
Highlighted
Occasional Contributor

Hi Thanks for a quick reply,
Well it would be very kind of you if you could give me the steps to start them and run the Sample project successfully
I have a demo to give on this .Kindly do the needful

Thanks in advance
Highlighted
Super Contributor

Hi!

1) Open the sample project
2) Right-click on the "SampleServiceSoapBinding MockService" and select the "Start Minimized" option
-> The MockService (hopefully) starts ok and minimizes itself to the bottom of the soapUI window
3) Now run the tests..

regards!

/Ole
eviware.com
Highlighted
Occasional Contributor

Hi ,

I tried what you said in your previous reply but tool hangs.
The stack trace that i am getting on the command window is as pasted below :
Looks like its asking for some jetty password.


17:57:03,064 INFO  [SchemaUtils] Added default schema from file:/C:/Program%20Fi
les/eviware/soapUI-Pro-2.0.2/lib/soapui-2.0.2.jar!/soapEncoding12.xsd with targe
tNamespace http://www.w3.org/2003/05/soap-encoding
17:57:03,080 INFO  [SchemaUtils] Loading schema types from [file:/D:/sample_.wsd
l/new_sample_.wsdl]
17:57:03,080 INFO  [SchemaUtils] Getting schema file:/D:/sample_.wsdl/new_sample
_.wsdl
17:57:03,861 ERROR [SoapMessageBuilder] Could not find element [{http://www.soap
ui.org/sample/}return_fault] specified in part [return_faultMsg]
jetty.ssl.password :

Regards,
Lakshmi
Highlighted
Super Contributor

Hi!

hmm.. I've never encountered this.. can you attach a screenshot of soapUI when you get this, showing the request window and http log?

regards!

/Ole
eviware.com
Highlighted
Occasional Contributor

Hi,

Have attached the snap shots of the Http log and the error log.The messages in these logs were empty.

Kindly also find a text log file attached for the same.


Regards,
Lakshmi
New Here?
Join us and watch the welcome video:
Announcements
Top Kudoed Authors