cancel
Showing results for 
Search instead for 
Did you mean: 

Test Suite failed even if test case executed with status OK

SOLVED
Highlighted
Occasional Contributor

Test Suite failed even if test case executed with status OK

Hello dear community

 

I have test suite with 6 test cases. 

test case 1: has 2 test steps - Groovy

test cases 2-5: they have usual HTTP Call test steps

test case 6:  has 1 test step - Groovy

 

When I start the Test Suite runner then and click play button the 1st test case is executed with status OK but test suite has FAILED status and the rest if the test cases are executed.

 

Could you please help me with it

1 ACCEPTED SOLUTION

Accepted Solutions
Frequent Contributor

Re: Test Suite failed even if test case executed with status OK

The Project and TestSuite will be considered to have failed if any single part fails.

 

From the run dialog, double click the failing test to drill down into the TestSuite and TestSteps until you find the root cause of the fail.

 

The failing step can be re-run to see the failure in detail

 

You can also examine the logs in the tabs towards the bottom of the screen.  I'll usually clear the logs from the right click menu before I re-run to remove any noise from other tests in the run.

 

 

2 REPLIES 2
Frequent Contributor

Re: Test Suite failed even if test case executed with status OK

The Project and TestSuite will be considered to have failed if any single part fails.

 

From the run dialog, double click the failing test to drill down into the TestSuite and TestSteps until you find the root cause of the fail.

 

The failing step can be re-run to see the failure in detail

 

You can also examine the logs in the tabs towards the bottom of the screen.  I'll usually clear the logs from the right click menu before I re-run to remove any noise from other tests in the run.

 

 

Occasional Contributor

Re: Test Suite failed even if test case executed with status OK

Hello dear community memeber

 

I checked the SoapUI logs and found Errors:

1) Fri Apr 19 12:43:47 CEST 2019:ERROR:An error occurred [com.eviware.soapui.plugins.auto.factories.AutoDiscoveryMethodFactory], see error log for details

 

2)  java.lang.IllegalStateException: Toolkit not initialized
at com.sun.javafx.application.PlatformImpl.runLater(PlatformImpl.java:273)
at com.sun.javafx.application.PlatformImpl.runLater(PlatformImpl.java:268)
at javafx.application.Platform.runLater(Platform.java:83)

 

First I fixed based on solution found here: https://community.smartbear.com/t5/SoapUI-Open-Source/AutoDiscoveryMethodFactory-ClassNotFoundExcept...

 

Second trying to fix. I found this similar reported issue in the following tread on your portal: https://community.smartbear.com/t5/SoapUI-Open-Source/SoapUI-5-5-0-will-not-run-project-or-suites-To...

 

Hopefully it will be solved. I will write there about my issue to support those ticket. 

 

I will close this trad as I pasted links to others. 

New Here?
Join us and watch the welcome video:
Join the exciting event
SeptemberHubBub
Top Kudoed Authors
Join the September Hub-bub to show off, learn and win