cancel
Showing results for 
Search instead for 
Did you mean: 

Some of my test cases are failing with 504 and 502 errors when run them as a test suite

Contributor

Some of my test cases are failing with 504 and 502 errors when run them as a test suite

Im having 40 test cases on my SoapUI project.

Two test cases are every time failing with the response code 502 and 504 when i run all the 40 test cases as a test suite.

 

But when I run them individually those two test cases are returning valid response with status code 200.

 

Is there any way to fix this?

 

 

3 REPLIES 3
Highlighted
Frequent Contributor

Re: Some of my test cases are failing with 504 and 502 errors when run them as a test suite

I don't think it's to do with your test, it could be your service that may not be able to respond that quickly.

 

Try adding some delays between the test and see if any difference?

 

 

Contributor

Re: Some of my test cases are failing with 504 and 502 errors when run them as a test suite

Yeah i tried with that ut still the same result. Man Sad May be you are correct this is somthing with the server.

Occasional Contributor

Re: Some of my test cases are failing with 504 and 502 errors when run them as a test suite

you must give us your test and your error. if you don't give precise information, we can't help you. 

Probably, you make a mistake in your conception. you modify a testsuite property in previous test cases,

so your test case becomes false.

New Here?
Join us and watch the welcome video:
Top Kudoed Authors