cancel
Showing results for 
Search instead for 
Did you mean: 

SOAP call from HPSM

New Member

SOAP call from HPSM

Hi experts,

 

  I'm facing a strange issue with my integration between HPSM and a custom system. I've always been using SOAPui to test credentials wsdls, actual calls.

  The problem right now is that everything works perfectly with soapUI but not with HPSM hence the fact that HPSM generates the very same xml "payload". In fact, if I copy the content from my logs and push it with soapUI everything works perfectly. I already ruled out authentication: If I mess up the credentials it's giving a total legit 200. Otherwise it's just "internal server error". I'm already connecting with the partner system developers but I don't realy have much hope in them. 

  I also know that this is more like an HPSM question but if any of you experts could just give me a hint what exactly could be different (not the xml content for sure) between the two cases it would be a huge help for me right now. Again:

Case1: SOAPUI call : everything checks out, legit answer with data comes back.

Case2:HPSM call with the very same credentials (acually very same computer), same content : fails -» internal server error

Authentication : basic pre-emptive/global (both work form SOAPUI)

xml attached

 

Any help hugely apprichiated!

Thanks in advance!

 

BR,

Dávid

 

1 REPLY 1
Community Hero

Re: SOAP call from HPSM

Could you do a Wireshark capture to check the difference?

 

Or get the other application to send it's SOAP request to a SoapUI MockService to examine the request.