cancel
Showing results for 
Search instead for 
Did you mean: 

POST multi/form-data cause error

Maksym_Khymii
Frequent Visitor

POST multi/form-data cause error

Hi. Using SoapUI Pro 5.1.2 version.

Execute attached POST request but get the error: 400 error Cannot read property 'data' of null.

The same request works well in Postman and Fiddler.

Seems SoapUI specific issue. Could you help to resolve that?

Maksym_Khymii_0-1619012193419.png

Maksym_Khymii_1-1619012245075.png

 

 

1 REPLY 1
richie
Community Hero

Re: POST multi/form-data cause error

Hey @Maksym_Khymii 

 

Your 'MediaType' attribute value is incorrect.  According to your screenshot, you've specified it as 'form-data' - but this isn't a valid value.

 

Replace 'form-data' with 'application/x-www-form-urlencoded'.  The MediaType dropdown generates the 'Content-Type' HTTP header value in your request

 

Also - in your payload you have included HTTP headers (Content-Type, Content-Transfer-Encoding, 'Content-Disposition) - you shouldn't be specifying these in the payload.

 

Also - it looks like you're setting the boundaries yourself in the payload - if setup correct, these are dynamically generated.  You should include JUST the payload and nothing else.

 

Hope this helps!

 

Cheers,

 

Rich

if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the Subject header field of the post to something more descriptive? This will help people when searching for problems. Ta
New Here?
Join us and watch the welcome video:
Top Kudoed Authors