I'm inviting you to a new Community challenge which we are starting next Monday (April 2)! Earn badges to get more points. Read more information
Reply
Highlighted
New Contributor
Accepted Solution

$MissingTransportException: Missing protocol in endpoint

How do I find out what transport protocol is missing?   I get the following message, but the error log is empty.  I added SSLv3,TLv1.2 to SOAP UI.

 

2018-01-12 16:25:38,209 INFO [SoapUI] Used java version: 1.8.0_152
2018-01-12 16:25:51,990 ERROR [SoapUI] An error occurred [com.eviware.soapui.impl.wsdl.submit.RequestTransportRegistry$MissingTransportException: Missing protocol in endpoint [https:/VSEGroup2.usa-ed.net:8056/sst/com.slma.ai01.ssl.Classv10.GetServicingProfile]], see error log for details
2018-01-12 16:25:51,990 ERROR [errorlog] com.eviware.soapui.model.iface.Request$SubmitException: com.eviware.soapui.impl.wsdl.submit.RequestTransportRegistry$MissingTransportException: Missing protocol in endpoint [https:/VSEGroup2.usa-ed.net:8056/sst/com.slma.ai01.ssl.Classv10.GetServicingProfile]
com.eviware.soapui.model.iface.Request$SubmitException: com.eviware.soapui.impl.wsdl.submit.RequestTransportRegistry$MissingTransportException: Missing protocol in endpoint [https:/VSEGroup2.usa-ed.net:8056/sst/com.slma.ai01.ssl.Classv10.GetServicingProfil

Posts: 5,161
Registered: ‎05-17-2013

Re: $MissingTransportException: Missing protocol in endpoint

What does it show in the Raw tab of request editor when you call the rest service from SoapUI?
New Contributor

Re: $MissingTransportException: Missing protocol in endpoint

[ Edited ]

The raw request only has below:

 

<missing raw request data>

 

This is for a SOAP service.

 

 

Posts: 5,161
Registered: ‎05-17-2013

Re: $MissingTransportException: Missing protocol in endpoint

Would you be able to show the screen shot of Request editor?
New Contributor

Re: $MissingTransportException: Missing protocol in endpoint

It appears that I accidently deleted a slash and that caused this issue.