cancel
Showing results for 
Search instead for 
Did you mean: 

Missing Raw Data

Highlighted
Occasional Contributor

Missing Raw Data

Hello,

I am still quite new to this fascinating tool, but I have done something and I don't know how to get it back.

Anyway, here goes.

Whilst processing a request, after I had submitted the request to an endpoint, if I clicked on the tab called raw, I would see a representation of what was sent over the wire. But now it has stopped working and all I get is the request headers.

How do I switch this brilliant functionality back on?
9 REPLIES 9
Highlighted
Moderator

Re: Missing Raw Data

Hello,

It's possible you may have accidentally modified a setting for this but I haven't found a setting that does this
Try restarting SoapUI and see if it resets back.


Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️
Highlighted

Re: Missing Raw Data

This could be a known issue where you have to change the following preferences:

File > Preference > Editor Settings tab > check "Validate Requests"
File > Preference > Editor Settings tab > check "Validate Responses"

Thanks,
Michael Giller
SmartBear Software


Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️
Highlighted
Occasional Contributor

Re: Missing Raw Data

I will give it a go and report back.
Highlighted
Occasional Contributor

Re: Missing Raw Data

Your a star.

Works perfectly.

Thank you very much.
Highlighted
Occasional Contributor

Re: Missing Raw Data

Just a thought thou, I have tested the code and the values that I receive into my WCF interface are not the same as was reported by SoapUI to be sent? Any ideas?
Highlighted

Re: Missing Raw Data

Which values are you comparing? Is SoapUI are you looking at the 'Raw' request editor and the 'HTTP Log' tab at the bottom?

Also where's the difference; in the message body or headers?

Thanks,
Michael Giller
SmartBear Software


Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️
Highlighted
Contributor

Re: Missing Raw Data

I am trying to explore SOAP UI tool and created a REST PRoject and trying to Invoke REST API and i get Missing raw response data . I am able to access REST API and get data when invoked via browser 

 

 

I have checked preference -Editor setting and validate requests and validate responses options are checked in but still give Missing raw response data 

 

Any Idea what else need to be checked ? 

Contributor

Re: Missing Raw Data

I am trying to explore SOAP UI tool and created a REST PRoject and trying to Invoke REST API and i get Missing raw response data . I am able to access REST API and get data when invoked via browser 

 

 

I have checked preference -Editor setting and validate requests and validate responses options are checked in but still give Missing raw response data 

 

Any Idea what else needs to be checked ? 

Highlighted
New Contributor

Re: Missing Raw Data

Is there another workaround for this?

I have tried setting the following:

File > Preference > Editor Settings tab > check "Validate Requests"
File > Preference > Editor Settings tab > check "Validate Responses"

 

but I'm still getting <missing raw request data> when running load test.

Normal execution works OK.

New Here?
Join us and watch the welcome video:
Announcements
Top Kudoed Authors