cancel
Showing results for 
Search instead for 
Did you mean: 

I have soap ui 5.4 , can i import postman collections in it ?

SOLVED
Highlighted
Contributor

I have soap ui 5.4 , can i import postman collections in it ?

I have soap ui 5.4 version , how can I import existing postman collection into it , which jar version I need

I don't have pro or ready api
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Contributor

Re: I have soap ui 5.4 , can i import postman collections in it ?

Yes in soap ui 5.4 its not possible , 5.5 , pro and ready api would work

View solution in original post

Tags (1)
7 REPLIES 7
Highlighted
Community Hero

Re: I have soap ui 5.4 , can i import postman collections in it ?

Hey @ameesh1984,

Have a look at thr following link. Ita the help for open source soapui postman plugin help.

https://www.soapui.org/docs/postman-collections/

Ta

Rich
if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the Subject header field of the post to something more descriptive? This will help people when searching for problems. Ta
Highlighted
Contributor

Re: I have soap ui 5.4 , can i import postman collections in it ?

Yes but I dont see that option to import the collection , where do I get the plugin for postman or the jar that works with soap ui 5.4 , to then import the collection

I see the plugin is for ready api only I need it for soap ui 5.4
Highlighted
Community Hero

Re: I have soap ui 5.4 , can i import postman collections in it ?

Hey @ameesh1984 

 

the followed the instructions i linked which were for soapui not readyapi!

 

see the following link - it all says soapui not readyapi!

 

you can download the plugin using the link embedded in the next page - https://www.soapui.org/extension-plugins/install/

 

nice one

 

Rich

if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the Subject header field of the post to something more descriptive? This will help people when searching for problems. Ta
Highlighted
Contributor

Re: I have soap ui 5.4 , can i import postman collections in it ?

When you search that page for postman plugin it says it's for ready api only
Highlighted
Community Hero

Re: I have soap ui 5.4 , can i import postman collections in it ?

Hey @ameesh1984 

 

Sorry - all the pages I was searching on I was searching for soapui - NOT readyAPI! -  the following page says the postman plugin works for SoapUI v5.3 above

 

https://www.soapui.org/docs/postman-collections/

 

however - Ive seen conflicting info on stackoverflow suggesting it doesn't work for soapui any longer.

 

You could download the trial version of ReadyAPI!, download and install the postman plugin, import the collection, save the new project (which converts the collection file into the project .xml) and then you can then open the project (that was generated from the postman collection) in SoapUI.

 

I wouldn't normally advocate avoidance of licensing - but it looks like the postman plugin used to work for soapui and they just stopped the support....and its not like youd be going beyond the trial

 

one thing though - before trying to use the postman plugin read all the details of its requirements to ensure your postman collection doesnt contain 'stuff' that the plugin wont import.  i played with the plugin about 3 years ago and the plugin wouldnt work with various conditions (it wouldn't import any parameterized attribute etc.) and in the end I just dropped it and just created the endpoints manually in ReadyAPI! instead.  The plugin just didnt support importing all the setup and config you can do in a postman collection.  that was a number of years ago and things may have changed - but its something worth thinking about before going to all that effort for no reason.

 

ta

 

Rich

if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the Subject header field of the post to something more descriptive? This will help people when searching for problems. Ta
Highlighted
Community Leader

Re: I have soap ui 5.4 , can i import postman collections in it ?

@ameesh1984 :

 

Don't know about soapui 5.4.0

 

but it is there in soapui 5.5.0, in File -> Import Postman Collection

refer below screenshot

 

HimanshuTayal_0-1592801767586.png

 


Click "Accept as Solution" if my answer has helped, and remember to give "kudos" 🙂 ↓↓↓↓↓



Thanks and Regards,
Himanshu Tayal
Highlighted
Contributor

Re: I have soap ui 5.4 , can i import postman collections in it ?

Yes in soap ui 5.4 its not possible , 5.5 , pro and ready api would work

View solution in original post

Tags (1)
New Here?
Join us and watch the welcome video:
Announcements
Top Kudoed Authors