cancel
Showing results for 
Search instead for 
Did you mean: 

How to enable TLS 1.2 in SoapUI

SOLVED
Highlighted
Regular Visitor

Re: How to enable TLS 1.2 in SoapUI

What should i change on my Mac to make it work?

Highlighted
Community Hero

Re: How to enable TLS 1.2 in SoapUI

Please go thru trailing messages, which already has answer I believe.


Regards,
Rao.
Highlighted
Occasional Contributor

Re: How to enable TLS 1.2 in SoapUI

what is the default TLS protocol version of Ready API 1.6.0?

Highlighted
Occasional Visitor

Re: How to enable TLS 1.2 in SoapUI

Hey guys, just faced also the prob with "handshake_failure".

For me it was due to a policy issue. soapui brings its own java environment, so for me it helped to actualize the policy in

 

...\SmartBear\SoapUI-5.2.1\jre\lib\security

 

with the policy files from:

 

http://www.oracle.com/technetwork/java/javase/downloads/jce8-download-2133166.html

 

hope that helped!

 

cheers,

 

SirDrinkalot

Highlighted
New Member

Re: How to enable TLS 1.2 in SoapUI

Install latest version 5.3.0 (open source) and it will resolve your issue. i also tried everything mentioned above but nothing worked. 

Highlighted
Frequent Visitor

Re: How to enable TLS 1.2 in SoapUI

I have SoapUI 5.3.0 and adding the line below to the vmoptions file worked for me!  I can now communicate with a SOAP service running on a server that only has TLS 1.2 enabled.

 

The file I added setting to:

C:\Program Files (x86)\SmartBear\SoapUI-5.3.0\bin\SoapUI-5.3.0.vmoptions

 

Line I added to end of file.

-Dsoapui.https.protocols=TLSv1.2

 

Good luck!

Highlighted
Contributor

Re: How to enable TLS 1.2 in SoapUI

Hello,

 

 

If none of the above options works for you ( just like i was banging my head ) , give a try to the below link

 

https://siking.wordpress.com/2016/02/18/another-way-to-fix-sslhandshakeexception-in-soapui/

 

kudos to the author and it makes perfect sense 🙂

 

Regards.

Highlighted
New Member

Re: How to enable TLS 1.2 in SoapUI

My Mac OS installation does not appear to have a vmoptions.txt file. I don't see it anywhere. The product installed in a directory called \HermesJMS, and it's \bin directory does not have this file.

Highlighted
Visitor

Re: How to enable TLS 1.2 in SoapUI

I can definitively say your suggestion resolved the issue for me (SoapUI 5.3.0, Windows 7 Enterprise x64 SP1). This is after more time wasted than I care to admit on numerous suggestions provided on various websites over the years.

 

Description of problem

Attempting to "Update Definition" by adding the WSDL via the hosted web service always resulted in a failure:

InvalidDefinitionException.png

though I could download the WSDL and add manually, no problem. Once the WSDL was added, however, attempting to call any method resulted in an exception:

SocketException.png

Adding

 

-Dsoapui.https.protocols=TLSv1.2

 

to "%PROGRAMFILES%\SmartBear\SoapUI-5.3.0\bin\SoapUI-5.3.0.vmoptions" resolved the issue completely -- I'm able to add/update the WSDL and invoke methods successfully.

 

Highlighted
New Contributor

Re: How to enable TLS 1.2 in SoapUI

New Here?
Join us and watch the welcome video:
Announcements
Top Kudoed Authors