cancel
Showing results for 
Search instead for 
Did you mean: 

HTTP Monitor not working - NullPointerException

New Contributor

HTTP Monitor not working - NullPointerException

Hello Fellow Coders,

 

I am trying to monitor the API operations using HTTP Monitor option in SoapUI. I have followed the exact same steps mentioned in following article:

https://www.soapui.org/http-recording/recording.html

 

However, when I trigger the request from SoapUI project, I always get following error if the HTTP Monitor is running:

<body>
<h2>HTTP ERROR 500</h2>
<p>
Problem accessing /CurrencyConvertor.asmx. Reason:
<pre>INTERNAL_SERVER_ERROR</pre>
</p>
<h3>Caused by:</h3>
<pre>java.lang.NullPointerException
at com.eviware.soapui.impl.wsdl.submit.AbstractMessageExchange.&lt;init>(AbstractMessageExchange.java:33)
at com.eviware.soapui.impl.wsdl.submit.AbstractWsdlMessageExchange.&lt;init>(AbstractWsdlMessageExchange.java:36)
at com.eviware.soapui.impl.wsdl.monitor.WsdlMonitorMessageExchange.&lt;init>(WsdlMonitorMessageExchange.java:28)
at com.eviware.soapui.impl.wsdl.monitor.JProxyServletWsdlMonitorMessageExchange.&lt;init>(JProxyServletWsdlMonitorMessageExchange.java:81)
at com.eviware.soapui.impl.wsdl.monitor.jettyproxy.ProxyServlet.service(ProxyServlet.java:143)
at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:511)
at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:401)
at org.mortbay.jetty.handler.ContextHandler.handle(ContextHandler.java:766)
at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:152)
at org.mortbay.jetty.Server.handle(Server.java:326)
at com.eviware.soapui.impl.wsdl.monitor.jettyproxy.JettyServer.handle(JettyServer.java:76)
at org.mortbay.jetty.HttpConnection.handleRequest(HttpConnection.java:542)
at org.mortbay.jetty.HttpConnection$RequestHandler.content(HttpConnection.java:945)
at org.mortbay.jetty.HttpParser.parseNext(HttpParser.java:756)
at org.mortbay.jetty.HttpParser.parseAvailable(HttpParser.java:218)
at org.mortbay.jetty.HttpConnection.handle(HttpConnection.java:404)
at org.mortbay.jetty.bio.SocketConnector$Connection.run(SocketConnector.java:228)
at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)

 

If I turn off the HTTP Monitor, then the request returns the valid response. I have tried with both SoapUI 5.2.0 and SoapUI 5.2.1, but the same error persists. [Refer attached screenshot of error.]

 

Could you suggest what else could be the problem? I noticed that someone else also has faced the same problem earlier; refer following post:

https://community.smartbear.com/t5/SoapUI-Open-Source/Version-5-2-1-Http-Monitor-not-working/m-p/110...

However, there is no solution posted in above post as well.

 

Appreciate if someone can help me here.

 

P.S. I also noticed that when HTTP Monitor is running, no other web services added in other projects are also getting executed. They are also throwing the same error mentioned above. And as soon as I turn off the HTTP Monitor, then all other projects work fine too. Since HTTP Monitor is intercepting all the traffic originated from SoapUI, may be there is some problem with HTTP Monitor's logic/configuration. Unable to figure out what though.

1 REPLY 1
Occasional Contributor

Re: HTTP Monitor not working - NullPointerException

Hi, did you resolve the problem? 

same issue with me.

New Here?
Join us and watch the welcome video:
Top Kudoed Authors