Ask a Question

Free Version : Load Test - SOAP Services

nghai_2021
New Contributor

Free Version : Load Test - SOAP Services

Hi Team 

I am facing something similar issue to https://community.smartbear.com/t5/API-Performance-Testing/The-document-is-not-a-Envelope-error-mess... .As there was no solution posted .So raising ticket again.

 

Test scenario : Create a member in the system.

Threads : 2 

Strategy: Simple 

Test Delay :2500

Random:0.5 

Limit =1.0 seconds

 

after running for 2 minutes i can see few of the requests fail with following error in 'LoadTest' log .

 

[SOAP Response] error: The document is not a Envelope@http://schemas.xmlsoap.org/soap/envelope/: document element mismatch got html@http://www.w3.org/1999/xhtml

[SOAP Response] The document is not a Envelope@http://schemas.xmlsoap.org/soap/envelope/: document element mismatch got html@http://www.w3.org/1999/xhtml

 

and After the full test run there are 5 errors shown under 'err' column . and if the complexity of the test is increased -i.e. Create a member and then create a account  , then the number of errors increase as well ( like 32 envelope errors).Checking the internal logs does not show any service related error . 

 

Can someone please help in understanding why only few requests fail with Soap envelope..

 does  changing any setting can help to resolve this.

 

Thanks

 

 

5 REPLIES 5
nmrao
Community Hero

Re: Free Version : Load Test - SOAP Services

It would be better to try send the SOAP request,. Once that is successful, then you can try load test.


Regards,
Rao.
nghai_2021
New Contributor

Re: Free Version : Load Test - SOAP Services

"thanks nmrao"...the single request works it self .. the requests work fine even i send 2 threads ...but what i have noticed that envelope error starts once the no of threads is increased and more over not all the requests fail .. thats where I am not sure what is causing the envelope error for some requests and not for other.

nmrao
Community Hero

Re: Free Version : Load Test - SOAP Services

So do you believe it is an issue with the application ? Best is to talk to your team.


Regards,
Rao.
nghai_2021
New Contributor

Re: Free Version : Load Test - SOAP Services

Not sure if it is an issue with application .. as I dnt see any deadlocking issue ..and it is increases rapidly with number of threads increased.and it happens with any call ..so may be tool is unable to wrap the requests too quickly ..I am not sure ..just a wild guess..

ebruh
Occasional Visitor

Re: Free Version : Load Test - SOAP Services

for this issue, you may contact or communicate with SmartBear Support - https://support.smartbear.com/

cancel
Showing results for 
Search instead for 
Did you mean: