cancel
Showing results for 
Search instead for 
Did you mean: 

Errors launching SoapUI 5.5.0

New Contributor

Errors launching SoapUI 5.5.0

I'm very new to SoapUI and not yet familiar with all the ins and outs.  Similar to another post here within the last day I am getting errors that I did not notice yesterday, or even this morning, when simply starting up SoapUI:

 

SoapUI errors.jpg

 

 

When I check the error.log file the two errors below are repeated 10x:

 java.lang.ClassNotFoundException: com.eviware.soapui.plugins.auto.factories.AutoImportMethodFactory
  at java.net.URLClassLoader.findClass(Unknown Source)
  at java.lang.ClassLoader.loadClass(Unknown Source)
  at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
  at java.lang.ClassLoader.loadClass(Unknown Source)
  at java.lang.Class.forName0(Native Method)
  at java.lang.Class.forName(Unknown Source)
  at com.eviware.soapui.plugins.LoaderBase.loadAutoFactories(LoaderBase.java:113)
  at com.eviware.soapui.plugins.LoaderBase.loadFactories(LoaderBase.java:80)
  at com.eviware.soapui.plugins.PluginLoader.loadPluginFactories(PluginLoader.java:141)
  at com.eviware.soapui.plugins.PluginLoader.loadPlugin(PluginLoader.java:104)
  at com.eviware.soapui.plugins.PluginLoader.loadPlugin(PluginLoader.java:54)
  at com.eviware.soapui.plugins.PluginManager.doInstallPlugin(PluginManager.java:141)
  at com.eviware.soapui.plugins.PluginManager.access$600(PluginManager.java:43)
  at com.eviware.soapui.plugins.PluginManager$LoadPluginsTask.computeSequentially(PluginManager.java:420)
  at com.eviware.soapui.plugins.PluginManager$LoadPluginsTask.compute(PluginManager.java:377)
  at com.eviware.soapui.plugins.PluginManager$LoadPluginsTask.compute(PluginManager.java:382)
  at com.eviware.soapui.plugins.PluginManager$LoadPluginsTask.compute(PluginManager.java:365)
  at java.util.concurrent.RecursiveTask.exec(Unknown Source)
  at java.util.concurrent.ForkJoinTask.doExec(Unknown Source)
  at java.util.concurrent.ForkJoinPool$WorkQueue.runTask(Unknown Source)
  at java.util.concurrent.ForkJoinPool.runWorker(Unknown Source)
  at java.util.concurrent.ForkJoinWorkerThread.run(Unknown Source)
 java.lang.ClassNotFoundException: com.eviware.soapui.plugins.auto.factories.AutoDiscoveryMethodFactory
  at java.net.URLClassLoader.findClass(Unknown Source)
  at java.lang.ClassLoader.loadClass(Unknown Source)
  at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
  at java.lang.ClassLoader.loadClass(Unknown Source)
  at java.lang.Class.forName0(Native Method)
  at java.lang.Class.forName(Unknown Source)
  at com.eviware.soapui.plugins.LoaderBase.loadAutoFactories(LoaderBase.java:113)
  at com.eviware.soapui.plugins.LoaderBase.loadFactories(LoaderBase.java:80)
  at com.eviware.soapui.plugins.PluginLoader.loadPluginFactories(PluginLoader.java:141)
  at com.eviware.soapui.plugins.PluginLoader.loadPlugin(PluginLoader.java:104)
  at com.eviware.soapui.plugins.PluginLoader.loadPlugin(PluginLoader.java:54)
  at com.eviware.soapui.plugins.PluginManager.doInstallPlugin(PluginManager.java:141)
  at com.eviware.soapui.plugins.PluginManager.access$600(PluginManager.java:43)
  at com.eviware.soapui.plugins.PluginManager$LoadPluginsTask.computeSequentially(PluginManager.java:420)
  at com.eviware.soapui.plugins.PluginManager$LoadPluginsTask.compute(PluginManager.java:377)
  at com.eviware.soapui.plugins.PluginManager$LoadPluginsTask.compute(PluginManager.java:382)
  at com.eviware.soapui.plugins.PluginManager$LoadPluginsTask.compute(PluginManager.java:365)
  at java.util.concurrent.RecursiveTask.exec(Unknown Source)
  at java.util.concurrent.ForkJoinTask.doExec(Unknown Source)
  at java.util.concurrent.ForkJoinPool$WorkQueue.runTask(Unknown Source)
  at java.util.concurrent.ForkJoinPool.runWorker(Unknown Source)
  at java.util.concurrent.ForkJoinWorkerThread.run(Unknown Source)

 

At the same time my CPU usage bounces around sporadically, especially when running a simple GET request.  On an i7-6700 CPU the usage goes as high as 82%.  I've restarted my machine twice this afternoon with no change.  SoapUI is currently frozen after initiating another simple GET request.  I've had to kill it multiple times via the Task Manager.

 

Any thoughts?

Thanks

2 REPLIES 2
Highlighted
Community Hero

Re: Errors launching SoapUI 5.5.0

Know issue. But nothing impact. You can ignore. Hope that is not stopping you using the tool.


Regards,
Rao.
New Contributor

Re: Errors launching SoapUI 5.5.0

Hi Rao,

 

I assume the issue is already under investigation.  SoapUI cetainly looks to be a powerful and easy tool to work with so I'll work with it as best I can.

 

It looks like a very active community, which is great to see!

 

Thanks,

Dave