cancel
Showing results for 
Search instead for 
Did you mean: 

Error message "You need to enable SoAP extension"

SWTester
Occasional Contributor

Error message "You need to enable SoAP extension"

Hello everyone,

 

i am new to this community & am not aware of the all the rules. I am search of the correct community to publish this message. If i am not on the correct community kindly navigate me to it. But still will post the problem i am facing. No offence intended  (or) disrespect towards anyone.

 

My Scenario: I need to integrate Mantis BTS with TestLink test management tool through interface:SOAPUI

 

My Problem: I am unable to establish a connection between SoapUI & Mantis BTS (i guess so). A message on TestLink "issue Tracker Management" is displayed as "You need to enable Soap extension"

 

My HW & SW details:

Mantis BTS:

MantisBT-Version: 1.2.15

Schema Version: 183

DB Type: mysql

I am not sure whether it supports https

Installed on a server

SoapUI details:

Version 5.2.1

Running on Vitual Machine (becuse as per company rules not allowed to install any SW on host)

TestLink details:

It is installed on Windows Server which is not the same as Mantis BTS

OS version: Windows Server 2012 R2

TestLink Version: 1.9.14

php-version: 5.5.29

MySQL Server: 5.6

Apache: 2.4.16

 

I will attach a picture of the architecture of all the installed tools for better understanding. The dotted line in green represents "communication is established but not connection". The dotted line in red denotes (probably) problem lies in that section

 

ITM architecture.PNG

Procedure followed to establish connection:

Mantis BTS <-> SoapUI

1) The WSDL file was acquired from the DB admin

2) Created a new SOAP Project with WSDL file in it.

3) All the necessary information was retrieved from the WSDL file. It was seen on the leftpane.

4) Then navigated to the MantisConnectBinding (testsuite) where under "Sevice Endpoints" required data were entered (Endpoint, Username, PW and domain)

5) Clicked "Assign Endpoint" tab and the corresponding databse was chosen

4) Checked the connection with the DB admin (A COMMUNICATION between Soap & Mantis was established but not sure whether CONNECTION was established to the DB)

 

On TestLink:

I made following changes in the php.ini file which is present in TestLink application packet.

1) "extension=php_soap.dll" command has been activated (earlier it was commented)

2) checked some files related to wsdl cache (everything activated but not sure how it will be useful in enabling SOAP extension)

 

Any suggestions is more than welcome & appreciated

 

Thank you in advance guys

3 REPLIES 3
nmrao
Community Hero

Re: Error message "You need to enable SoAP extension"

Welcome to the community.

I happen to land in below link, please see if that helps if you already not been to there.
http://forum.testlink.org/viewtopic.php?f=44&t=7191


Regards,
Rao.
SWTester
Occasional Contributor

Re: Error message "You need to enable SoAP extension"

Hey dude,

 

thanks a lot for that link. I had already checked it out before couple of weeks. It didn't solve my issue. But will give it a try once again 🙂 maybe missed out something.

 

br

pradeep 

SWTester
Occasional Contributor

Re: Error message "You need to enable SoAP extension"

Hey, i looked at the link once again.

 

Height of misinterpretation: I misinterpreted interface:SOAP (i.e. SOAP protocol) as SoapUI

 

My approach to the scenario was totally WRONG. In this scenario i should have not used SoapUI tool to connect TestLink & Mantis BTS but i should have used SOAP Protocol for the connection. 

New Here?
Join us and watch the welcome video:
Top Kudoed Authors