cancel
Showing results for 
Search instead for 
Did you mean: 

Error Loading WSDL file - Unexpected element CDATA

Highlighted
New Member

Error Loading WSDL file - Unexpected element CDATA

Hi,

I'm trying to load a WSDL file and I am getting an "unexpected element CDATA" error.  Any help with this would be greatly appreciated. 

 

Thanks,

Randy

1 REPLY 1
Highlighted
Community Hero

Re: Error Loading WSDL file - Unexpected element CDATA

Hey @Larsenrw22,

You didnt extract the .wsdl from an MS product did you? Im sure someone else had an issue trying to load in a .wsdl generated from something like MS Dynamics recently.

Anyway. Youre likely getting this error response due to either an entity (e.g.  ) not being recognised by the default character set soapui's parser is using or you have some malformed .xml in the .wsdl (yes i appreciate another tool will have generated the .wsdl so you wouldnt expect it to be malformed).

Try launching the .wsdl into another app that has an xml parser....in a browser or notepad++ (with xmlplugin) or better still XMLSpy.

Im expecting some sort of error (if ita malformed) or a warning if theres a problem with a certain character (unrecognised entity value like  ).

When ive had this problem before i tried loading the file into xmlspy, and then manually fixed the issue so that the xml was wellformed. Once the xml in the .wsdl is wellformed, the .wsdl will load in soapui without any problems manifesting.

Cheers

Rich
if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the Subject header field of the post to something more descriptive? This will help people when searching for problems. Ta
New Here?
Join us and watch the welcome video:
Announcements
Top Kudoed Authors