cancel
Showing results for 
Search instead for 
Did you mean: 

Eclipse crach after instal of soapUI plugin on OS X Leopard

New Contributor

Eclipse crach after instal of soapUI plugin on OS X Leopard

Hi I'm a soapUI newb having some problems the eclipse plugin eclipse europe on OS X Leopard .

After installing the soapUI eclipse plugin eclipce crashes during start up with this information in the eclipse log file:

!SESSION 2008-02-01 09:02:12.341 -----------------------------------------------
eclipse.buildId=M20071023-1652
java.version=1.5.0_13
java.vendor=Apple Inc.
BootLoader constants: OS=macosx, ARCH=x86, WS=carbon, NL=en_US
Command-line arguments:  -os macosx -ws carbon -arch x86

!ENTRY org.eclipse.ui 4 0 2008-02-01 09:02:29.949
!MESSAGE Unhandled event loop exception
!STACK 0
java.lang.InternalError: Can't start the AWT because Java was started on the first thread.  Make sure StartOnFirstThread is not specified i
n your application's Info.plist or on the command line

I modify my eclipse.ini file accordingly:
Substituting "-XstartOnFirstThread" for "-Djava.awt.headless=true"

Still the same error message.

Have anyone got a clue how to fix this?
3 REPLIES 3
Contributor

Re: Eclipse crach after instal of soapUI plugin on OS X Leopard

Hi Rikard!

This seems to be a problem with the upgrade to Leopard. See http://lists.apple.com/archives/java-de ... 00371.html.

I'm afraid we don't have a solution for this, since you already tried to set -Djava.awt.headless=true. JBossIDE has the same problem (http://jira.jboss.org/jira/browse/JBIDE-1376) and they are waiting for Eclipse 3.3.2 to fix it.

Regards,
Lars
Contributor

Re: Eclipse crach after instal of soapUI plugin on OS X Leopard

Hi again,

One possibility is to try a 3.3.2 or 3.4 build at http://download.eclipse.org/eclipse/downloads/.
I cannot test this myself, because I am still using Tiger.

Regards,
Lars
New Contributor

Re: Eclipse crach after instal of soapUI plugin on OS X Leopard

I've tried the 3.4M4 build of eclipse on MacOS X Leopard and it works (browsed around for 5 mins and so far it works).

Thanks a lot for the suggestion.

However I still have a problem with keyboard typing characters like @[] , the same problem exists for the soapUI application.  Do you have a fix for that as well?

Thanks a lot for your help Lars.

Best Regards

--rikard
New Here?
Join us and watch the welcome video:
Top Kudoed Authors