cancel
Showing results for 
Search instead for 
Did you mean: 

ERROR [AbstractTestRunner] Exception during Test Execution

SOLVED
Occasional Contributor

ERROR [AbstractTestRunner] Exception during Test Execution

Bonjour,
Depuis que j'ai installé la nouvelle version 5.5 SOAPUI , j'ai un message d'error dans le fichier de log soapui.log:

 

2019-02-14 12:20:34,692 ERROR [AbstractTestRunner] Exception during Test Execution
java.lang.IllegalStateException: Toolkit not initialized
	at com.sun.javafx.application.PlatformImpl.runLater(PlatformImpl.java:273)
	at com.sun.javafx.application.PlatformImpl.runLater(PlatformImpl.java:268)
	at javafx.application.Platform.runLater(Platform.java:83)
	at com.eviware.soapui.impl.wsdl.panels.project.WsdlProjectTestSuitesTabPanel$InternalTestSuiteRunListener.afterTestSuite(WsdlProjectTestSuitesTabPanel.java:378)
	at com.eviware.soapui.impl.wsdl.testcase.WsdlProjectRunner.notifyAfterRunTestSuite(WsdlProjectRunner.java:196)
	at com.eviware.soapui.impl.wsdl.testcase.WsdlProjectRunner.runSequential(WsdlProjectRunner.java:123)
	at com.eviware.soapui.impl.wsdl.testcase.WsdlProjectRunner.internalRun(WsdlProjectRunner.java:87)
	at com.eviware.soapui.impl.wsdl.testcase.WsdlProjectRunner.internalRun(WsdlProjectRunner.java:40)
	at com.eviware.soapui.impl.wsdl.support.AbstractTestRunner.run(AbstractTestRunner.java:128)
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
	at java.util.concurrent.FutureTask.run(FutureTask.java:266)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
	at java.lang.Thread.run(Thread.java:748)

Avec la version 5.4, tout est ok, je n'ai pas de message d'erreur.

Mon environnement :

  • MacOs Mojave
  • java version "11.0.2" 2018-10-16 LTS
  • Java(TM) SE Runtime Environment 18.9 (build 11.0.2+7-LTS)
  • Java HotSpot(TM) 64-Bit Server VM 18.9 (build 11.0.2+7-LTS, mixed mode)

Pouvez vous m'aider à résoudre ce problème ?

 

1 ACCEPTED SOLUTION

Accepted Solutions
Occasional Contributor

Re: ERROR [AbstractTestRunner] Exception during Test Execution

Thanks you very much.
My problem is solved .. it is a bug from this version . 
If i uncheck this option => i can not run all my testSuite
If i check this option => it ok

i hope the next update will fixe this bug.

8 REPLIES 8
Community Hero

Re: ERROR [AbstractTestRunner] Exception during Test Execution

Please translate the post to english and repost. Sorry about it.


Regards,
Rao.
Occasional Contributor

Re: ERROR [AbstractTestRunner] Exception during Test Execution

Hello,
Since I installed the new 5.5 SOAPUI version, I have an error message in the soapui.log log file:

2019-02-14 12:20:34,692 ERROR [AbstractTestRunner] Exception during Test Execution
java.lang.IllegalStateException: Toolkit not initialized
	at com.sun.javafx.application.PlatformImpl.runLater(PlatformImpl.java:273)
	at com.sun.javafx.application.PlatformImpl.runLater(PlatformImpl.java:268)
	at javafx.application.Platform.runLater(Platform.java:83)
	at com.eviware.soapui.impl.wsdl.panels.project.WsdlProjectTestSuitesTabPanel$InternalTestSuiteRunListener.afterTestSuite(WsdlProjectTestSuitesTabPanel.java:378)
	at com.eviware.soapui.impl.wsdl.testcase.WsdlProjectRunner.notifyAfterRunTestSuite(WsdlProjectRunner.java:196)
	at com.eviware.soapui.impl.wsdl.testcase.WsdlProjectRunner.runSequential(WsdlProjectRunner.java:123)
	at com.eviware.soapui.impl.wsdl.testcase.WsdlProjectRunner.internalRun(WsdlProjectRunner.java:87)
	at com.eviware.soapui.impl.wsdl.testcase.WsdlProjectRunner.internalRun(WsdlProjectRunner.java:40)
	at com.eviware.soapui.impl.wsdl.support.AbstractTestRunner.run(AbstractTestRunner.java:128)
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
	at java.util.concurrent.FutureTask.run(FutureTask.java:266)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
	at java.lang.Thread.run(Thread.java:748)

With version 5.4 I dont have this error message.
I work with:
* Mojave MacOs
* java version "11.0.2" 2018-10-16 LTS
* Java (TM) SE Runtime Environment 18.9 (build 11.0.2 + 7-LTS)
* Java HotSpot (TM) 64-Bit VM Server 18.9 (build 11.0.2 + 7-LTS, mixed mode)

Can you help me solve this problem?

Community Hero

Re: ERROR [AbstractTestRunner] Exception during Test Execution

Understand that 5.5.0 got released couple of days back.

Already noticed couple of issues in this forum by community members.

At the moment, it would be better to continue to use 5.4.0 if you are not able to proceed with 5.5.0.

It would always be good to check for the release notes of the new software release before upgrading and see yourself how it is going to help upgrading before hand.


Regards,
Rao.
Highlighted
Occasional Contributor

Re: ERROR [AbstractTestRunner] Exception during Test Execution

For the moment, it's not a blocking problem.
But i need SOAPUI with java version 8 for a entreprise project.

New Contributor

Re: ERROR [AbstractTestRunner] Exception during Test Execution

Re: SoapUI 5.5.0 will not run project or suites - Toolkit not initialized error

I had this issue and I seem to have worked my way out of it.

 

1 - Save your workspace as a new workspace.

2 - Delete the default-soapui-workspace.xml file. (user folder)

3 - Open SoapUI again and switch to the new workspace.

 

This puts everything back to defaults, though I've been able to make changes that puts my setup back to the way I liked it without breaking anything.

Occasional Contributor

Re: ERROR [AbstractTestRunner] Exception during Test Execution

I deleted my workspace file.
I created a new workspace then i imported my project in this new workspace but i see again the same error message.

 

<?xml version="1.0" encoding="UTF-8"?>
<con:soapui-workspace name="V3Workspace" soapui-version="5.5.0" xmlns:con="http://eviware.com/soapui/config">
  <con:settings/>
  <con:project name="V3_DolmenWebServices">/Users/aurelien.galpin/ProjetSoapui/DContactV3-soapui-project.xml</con:project>
</con:soapui-workspace>

I think that the XML file project contains old properties based on version 5.4.0 SOAPUI.
Extract of my projet.xml

<?xml version="1.0" encoding="UTF-8"?>
<con:soapui-project id="ff2c8e2f-ba34-4eb9-b98a-96f3b06eb4aa" activeEnvironment="Default" name="V3_DolmenWebServices" resourceRoot="" soapui-version="5.5.0" abortOnError="false" runType="SEQUENTIAL" xmlns:con="http://eviware.com/soapui/config">
  <con:description>Scénarios permettant de tester la non regression fonctionnelle sur DataContact.Base de données piloval : network_id = 2697</con:description>
  <con:settings>
    <con:setting id="com.eviware.soapui.impl.wsdl.actions.iface.tools.soapui.TestRunnerAction@values-local"><![CDATA[<xml-fragment xmlns:con="http://eviware.com/soapui/config">
      <con:entry key="Report Format(s)" value=""/>
      <con:entry key="Host:Port" value=""/>
      <con:entry key="Export JUnit Results" value="true"/>
      <con:entry key="Export All" value="true"/>
      <con:entry key="Save After" value="false"/>
      <con:entry key="Add Settings" value="false"/>
      <con:entry key="WSS Password Type" value=""/>
      <con:entry key="TestSuite" value="&lt;all>"/>
      <con:entry key="Endpoint" value=""/>
      <con:entry key="Select Report Type" value=""/>
      <con:entry key="System Properties" value=""/>
      <con:entry key="Password" value=""/>
      <con:entry key="Print Report" value="false"/>
      <con:entry key="Open Report" value="false"/>
      <con:entry key="Export JUnit Results with test properties" value="true"/>
      <con:entry key="Global Properties" value=""/>
      <con:entry key="Project Properties" value=""/>
      <con:entry key="Project Password" value=""/>
      <con:entry key="TestCase" value="&lt;all>"/>
      <con:entry key="Username" value=""/>
      <con:entry key="user-settings.xml Password" value=""/>
      <con:entry key="TestRunner Path" value=""/>
      <con:entry key="Environment" value="Default"/>
      <con:entry key="Coverage Report" value="false"/>
      <con:entry key="Enable UI" value="false"/>
      <con:entry key="Root Folder" value="/Users/aurelien.galpin/Documents/Templates"/>
      <con:entry key="Ignore Errors" value="true"/>
      <con:entry key="Domain" value=""/>
      <con:entry key="Tool Args" value=""/>
      <con:entry key="Save Project" value="false"/>
      </xml-fragment>]]></con:setting>
    </con:settings>
    <con:interface xsi:type="con:RestService" id="4c6bcc49-5ec0-4af4-9bbd-55292c7b0295" wadlVersion="http://wadl.dev.java.net/2009/02" name="idolData Contact API" type="rest" basePath="/iDolDataContact" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
      <con:description>Data Contact API documentation</con:description>
      <con:settings/>
      <con:definitionCache type="TEXT" rootPart=""/>
      <con:endpoints>
        <con:endpoint>http://beg1-pre.dolmen-tech.com:8080</con:endpoint>
      </con:endpoints>
      <con:resource name="/batch/bdc/{networkNodeId}" path="/batch/bdc/{networkNodeId}" id="133ee00b-5c3d-4fd5-978c-cccb36d66008">
        <con:settings/>
        <con:parameters/>

 

 

New Contributor

Re: ERROR [AbstractTestRunner] Exception during Test Execution

Ok, I think I actually figured it out.. I can actually break and fix the issue with this one setting.

 

Leave it so that start page opens and it seems to work. If you uncheck this and restart SoapUI, at least from what I've been able to reproduce, it causes this issue:


1.JPG

 

Occasional Contributor

Re: ERROR [AbstractTestRunner] Exception during Test Execution

Thanks you very much.
My problem is solved .. it is a bug from this version . 
If i uncheck this option => i can not run all my testSuite
If i check this option => it ok

i hope the next update will fixe this bug.

New Here?
Join us and watch the welcome video: