cancel
Showing results for 
Search instead for 
Did you mean: 

Does Soap ui supports swagger 3.0 or open api 3.0 importing api spec (json) file

Regular Visitor

Does Soap ui supports swagger 3.0 or open api 3.0 importing api spec (json) file

Hi,

Does Soap ui supports swagger 3.0 or open api 3.0 import/exporting  api spec (.json) file.

3 REPLIES 3
Highlighted
New Contributor

Re: Does Soap ui supports swagger 3.0 or open api 3.0 importing api spec (json) file

Same question here. Some with more solutions help us. Thanks in advance.

 

Regards,

Shane.

Occasional Contributor

Re: Does Soap ui supports swagger 3.0 or open api 3.0 importing api spec (json) file

when i use "import swagger" function, the soapui shows me follow message:

"groovy.json.JsonException: Unable to determine the current character, it is not a string, number, array, or object The current character read is 'o' with an int value of 111 Unable to determine the current character, it is not a string, number, array, or object line number 1 index number 0 openapi: 3.0.0 ^"

 

i was able to import after edit yaml/json spec:

change (openapi: 3.0.0)  to (swagger: "2.0") on first line of archive

Community Hero

Re: Does Soap ui supports swagger 3.0 or open api 3.0 importing api spec (json) file

If 3.0 features are being used, just changing it to 2.0 may not work.


Regards,
Rao.
February News
Top Kudoed Authors