cancel
Showing results for 
Search instead for 
Did you mean: 

0 running soapUI MockServices: is it a bug ?

New Contributor

0 running soapUI MockServices: is it a bug ?

Hello,

I built a Test Case with these 5 steps:
1 Properties
2 Monk Response (waits for a request from System-A and then returns a response)
3 Property Transfer
4 Delay
5 TestRequest (submit a request to System-B and validate the response)

When I run this TestCase it works as expected.
If I select "Loop TestCase continuously" it works too.
But, if at the end of the TestCase I add a "Conditional Goto" step then only the first loop works.

At the beginning of the second loop System-A complains that the reply sent by soapUI contains HTML.
In fact this reply sent by the “Monk Reponse” step during the second loop is :
<html><body><p>There are currently 0 running soapUI MockServices</p><ul></ul></p></body></html>

Why ?

I’m using soapUI 3.6.1 (Build dist-111-2010-10-18, Build Date 2010/10/18 14:57

Thanks.
2 REPLIES 2
Highlighted
New Contributor

hi,

It is not a bug. It means Your mock service is not started. try with generate mock service and still still it does not work then restart your system.
Highlighted
New Contributor

No magic! Rebooting the PC is not a solution...
Here more detail on my problem:

* To make the loop I follow instructions found here : 6.1. Loop a sequence of TestSteps X times.
This means I added a Groovy step at the end of my TestCase with this code:
testRunner.gotoStepByName( "Name of first TestStep in loop" )


* When the body of the loop is executed for the first time the MockResponce step handles the request as expected but when the body is executed for the second time soapUI replies to the incomming request with this html message : "0 running soapUI MockServices".

How can I restart/reset/re-initialise the MockResponse step ?

Note: It works when I use the option "LoopTest continuously" (the loop is generated by soapUI)
But it seems impossible to activate this option from command line of by a script and so not available when run in batch mode with testrunner.
New Here?
Join us and watch the welcome video:
Announcements
Top Kudoed Authors