Ask a Question

Still running V5.5.0

Mis3
Frequent Contributor

Still running V5.5.0

I am still running V5.5.0 and I noticed that V5.6 has been around for a long time.

I clicked Check for Updates in Help, it says "You are using the latest accessible release of SoapUI".   What does this mean?

 

What is the best way to upgrade with least impact to my projects?

Thanks.

6 REPLIES 6
richie
Community Hero

Hey @Mis3 

 

 

It sounds like there's a defect in SoapUI - cos there's actually v5.7.0 been released, so v5.6 is not the latest.

 

You could always navigate to here -->  http://soapui.org/downloads/latest-release to manually download the latest version.  It's a bit weird that SoapUI isn't finding v5.7.0 as the latest release - but at least you can manually download from the above link.

 

The "best way to upgrade with least impact to my projects"?  You can read the release notes for each new version of SoapUI before installing to see if any of the changes might impact your tests. 

Another option (which is what I tend to do instead) is ignore the release notes initially and download the latest version, but I don't upgrade the existing folder in the program files directory - but install into a separate folder - so that I actually have multiple versions of SoapUI installed at the same time - so that if there's a problem with the latest version, I've still got the previous version to go back to.

 

I did notice someone else posted an issue about how the JSON libaries appear to have been updated in v5.7.0 and so some of your tests using JSONPATH might fail due to changes.  So in that instance the API tester involved needed to determine if the work required to the JSONPATH in his tests was worth the upgrade or not.

 

Hope this helps,

 

Cheers,

 

Rich 

if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the Subject header field of the post to something more descriptive? This will help people when searching for problems. Ta
Mis3
Frequent Contributor

Thanks for your help.

V5.7 is still new, maybe I should just upgrade to V5.6.

 

 

 

 

Mis3
Frequent Contributor

I downloaded SoapUI-5.6.1-windows-bin, unzipped it but I cannot found an executable file to update.

I tried SoapUI-5.6.0-windows-bin, same result.

 

Did i download the wrong files?

richie
Community Hero

Hey @Mis3 

 

yep - the bin.zip contains the bin files installed (what you see in the Program Files/SmartBear/SoapUI directory)

 

just download the relevant install executable (the .exe file version) instead.

 

once downloads, double click to expand and launch the install

 

Cheers

 

Rich

if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the Subject header field of the post to something more descriptive? This will help people when searching for problems. Ta
Mis3
Frequent Contributor

Thanks for your advice. 
I downloaded the EXE and installed V5.6.1.  I pinned the new version to the taskbar.


Strange that now I see both V5.5 icon and V5.6.1 icon on the taskbar.  My expectation is the new version would replace the old one.

 

My question is do both versions work on the same projects in SOAPUI-Projects folder?   More specifically, let say I changes something in project abc in V5.5 and saved the project in V5.5.   When I launch SoapUI in V5.6.1 and open this project, would I see the changes I did earlier in V5.5?  

Mis3
Frequent Contributor

I installed SoapUI 5.7.0 and now I have both SoapUI  5.6.1 and 5.7.0 in my laptop.

I noticed that in V5.7.0, the response is RAW.  

How do I change the default to XML?  Don't want to have to click on XML every time.

 

 

cancel
Showing results for 
Search instead for 
Did you mean: