Ask a Question

SoapUI GUI repaint issues

rsulliv1
Occasional Contributor

SoapUI GUI repaint issues

Anyone else having similar GUI repaint issues similar to what's noted in this thread:

 

https://community.smartbear.com/t5/SoapUI-NG/screen-refresh-issue-in-GUI/td-p/10026

 

I've attempted to enable & disable the native ui (no effect) and add the java param to the .vmoptions file (no effect).

 

I'm thinking it's related to the installed jre since I have been using 5.2.0 for a while without issue. I haven't used SoapUI in a few months, so it's likely java has been updated since then.

 

I noticed the issue on that version today. I upgraded to 5.2.1 and see the same issue.

8 REPLIES 8
Kostya
Visitor

Have the same issue with both 5.1.2 and Ready! API 1.9.0

Using Windows 7 x64, tried with Java 8u111 and 8u77

Need a solution ASAP

rsulliv1
Occasional Contributor

 

 

No updates from my side. still dealing with it even today. on version 5.3.0, but as you can see from the screenshot, the UI is still a mess.

 

rsulliv1
Occasional Contributor

tried to switch the java_home to see if using x86 vs x64 worked. jre 1.7 vs 1.8; but nothing seems to bypass this terrible UI issue. completely makes the app unusable 😞

 

I'd even pay for a soap license if I knew there was any chance of this being fixed in a paid version.

rsulliv1
Occasional Contributor

and another screenshot. this is after about 30s of attempting to setup a test.

rsulliv1
Occasional Contributor

Issue still exists as of 2/24. 

 

Anyone else having this issue? there must be something else on the system causing this issue since there's no way to downgrade to any other soapui version to avoid the issue.

 

Please see attached video. very interesting behavior. on my primary monitor, the app doesn't work for more than a few moments... but, the UI repaints itself and works perfectly if I drag the window to the secondary monitor.

 

I put the green line where the crossover point is between monitors since the screencapture makes it difficult to tell there are two monitors being captured (see the wallpaper split in the background)

nmrao
Community Hero

@Kostya,
If you have ReadyAPI license, you should be able to contact customer support using below link.

https://support.smartbear.com/product-list/


Regards,
Rao.
nmrao
Community Hero

@rsulliv1, if you follow the link mentioned,
adding below seemed helped the poster of the question:

set JAVA_OPTS=%JAVA_OPTS% -Dsoapui.jxbrowser.disable="true"


Regards,
Rao.
rsulliv1
Occasional Contributor

Adding that property (added to .bat & .vmoptions files both and tried each separately as well) had no effect.

 

Also, it seemed stable if I used my secondary monitor, but that's no longer the case. it seems that switching monitors merely forced a repaint, but didn't actually affect the overall issue. If I use the app for longer than a min or two on either monitor, the screen goes to hell.

 

Not sure what's going on.

cancel
Showing results for 
Search instead for 
Did you mean: