Ask a Question

Bug in Selenium support in soapUI groovy script

klusht
Occasional Contributor

Bug in Selenium support in soapUI groovy script

Hi ,

 

I did so many test, to make this working , and unfortunately was unsuccessful for new soapUI versions. It works fine in older ones (like v 4.0.0)
Steps to reproduce defect :
1 - load jars in ext :

\bin\ext\geb-ast-0.10.0.jar] to extensions classpath

\bin\ext\geb-core-0.10.0.jar] to extensions classpath
\bin\ext\geb-spock-0.10.0.jar] to extensions classpath
\bin\ext\geb-waiting-0.10.0.jar] to extensions classpath
\bin\ext\gson-2.3.1.jar] to extensions classpath
\bin\ext\ivy-2.1.0.jar] to extensions classpath
\bin\ext\jna-4.1.0.jar] to extensions classpath
\bin\ext\platform-3.4.0.jar] to extensions classpath
\bin\ext\selenium-api-2.46.0.jar] to extensions classpath
\bin\ext\selenium-chrome-driver-2.46.0.jar] to extensions classpath
\bin\ext\selenium-firefox-driver-2.46.0.jar] to extensions classpath
\bin\ext\selenium-ie-driver-2.46.0.jar] to extensions classpath
\bin\ext\selenium-remote-driver-2.46.0.jar] to extensions classpath
\bin\ext\selenium-server-2.46.0.jar] to extensions classpath
\bin\ext\selenium-support-2.46.0.jar] to extensions classpath
\bin\ext\spock-core-1.0-groovy-2.4.jar] to extensions classpath

>>>> for testing in v.4.0.0 , please add guava-18.0.jar as well

- update lib jars

\lib\groovy-all-2.4.3.jar

\lib\httpcore-4.4.1.jar

\lib\httpclient-4.5.jar

\lib\guava-18.0.jar

 

2- execute groovy script :

import geb.Browser

def browser = new Browser()

browser.drive({
     go "http://www.google.com/"
})

 

3 - result : 

The browser is launched for a second , and killed with error:

org.openqa.selenium.remote.UnreachableBrowserException: Could not start a new session. Possible causes are invalid address of the remote server or browser start-up failure. Build info: version: '2.46.0', revision: '61506a4624b13675f24581e453592342b7485d71', time: '...........' System info: host: '........', ip: '........', os.name: 'Windows 7', os.arch: 'amd64', os.version: '6.1', java.version: '1.7.0_55' Driver info: driver.version: FirefoxDriver error at line: 3

 

-If you make the same setup in version 4.0.0 the test PASSES. 

-tested with chromedriver.exe ,  and same results

 

I cannot make any assumptions as they will be wrong for sure 🙂

 

Can someone fix this issue 🙂 . I am waiting for this fix for a loooong time, and it would be nice to fix this as we would be able to cover web automations in soapUI.

 

same issue :

http://stackoverflow.com/questions/30397043/selenium-unreachablebrowserexception-could-not-start-a-n...

 

6 REPLIES 6
nmrao
Community Hero

Just a quick check, what is the current latest SOAPUI Open Source version on which you see this behaviour.


Regards,
Rao.
klusht
Occasional Contributor

Hi Rao,

 

Tested on 

SoapUI-5.2.0-beta , java 1.7

and 

SoapUI-5.1.3 , java 1.8

 

Regards, 

klusht

nmrao
Community Hero

I am trying the same on 5.2 release, but that is leading to different issue altogether.
Any way, see if this link helps:
http://stackoverflow.com/questions/22425565/selenium-exceptionin-java-org-openqa-selenium-remote-unr...
which says:
set the path to the chromedriver.exe and it worked. C:\\Program Files (x86)\\chromedriver\\chromedriver.exe


Regards,
Rao.
klusht
Occasional Contributor

Hi,
I did that test. As mentioned in my first post I did use chromedriver.exe and not chrome.exe .
Thanks for suggesting this, it is good to have all possible problems in one place

Regards,
klusht
nmrao
Community Hero

So that did not help your case, right?


Regards,
Rao.
klusht
Occasional Contributor

Hi Rao,
No that did not fix the issue 🙂 I thought it was obvious from my answer 🙂
cancel
Showing results for 
Search instead for 
Did you mean: