cancel
Showing results for 
Search instead for 
Did you mean: 

Deploy multiple war file with different port number not working.

Contributor

Deploy multiple war file with different port number not working.

Hi Team,

 

I have created 3 projects war file and I have placed under the webapps folder of Tomcat. If I have only 1 war file it works perfectly fine. We have a requirement to do different setup for various projects according to which, virtualization should be able to provide service by operating at various port numbers. Please let me know how can we achive this? Can we do this through any config files?

 

Thanks

Senthil.

2 REPLIES 2
Highlighted
Community Hero

Re: Deploy multiple war file with different port number not working.

Hi,

 

Have you followed steps documented here: https://support.smartbear.com/readyapi/docs/servicev/running/deploy-in-war-format.html ?

What exactly does not work if the above does not help?

 

Regards,
Alex
[Community Expert Group]
____
[Community Expert Group] members are not employed by SmartBear Software but
are just volunteers who have some experience with the tools by SmartBear Software
and a desire to help others. Postings made by [Community Expert Group] members
may differ from the official policies of SmartBear Software and should be treated
as the own private opinion of their authors and under no circumstances as an
official answer from SmartBear Software.
[Community Expert Group] signature is used with permission by SmartBear Software.
http://smartbear.com/forums/f83/t86934/community-experts/
================================
Highlighted
Contributor

Re: Deploy multiple war file with different port number not working.

Hi Alex,

 

Thanks for the update, Yes I did followed the same steps to create war file. Now my question here is,

1. ABC-Services.war

2. DEF-Servcies.war 

3. 123-Services.war

Now I need these application war to be run on different port, How, can I achive this? I am deploying the application war files in tomcat server. 

 

I have all my service protocal configured as http, but 

This format does not work "http://virinf0002vt.metest.local:8088/ABC-Services/"

This format does work https://virinf0002vt.metest.local:8088/ME-Services/
Could you please let me know why does it not work for http ?

 

Thanks

Senthil