Ask a Question

oauth 1.0 support

SOLVED
PCampbell
Regular Visitor

oauth 1.0 support

How can I set up ReadyAPI for Rest functional testing if my app uses Oauth 1.0? Thanks

1 ACCEPTED SOLUTION

Accepted Solutions
nmrao
Community Hero

Re: oauth 1.0 support

This the link to oauth2, but you give a try and see, post the problem if there is any specific issue.
http://readyapi.smartbear.com/features/auth/types/oauth2/start


Regards,
Rao.

View solution in original post

2 REPLIES 2
nmrao
Community Hero

Re: oauth 1.0 support

This the link to oauth2, but you give a try and see, post the problem if there is any specific issue.
http://readyapi.smartbear.com/features/auth/types/oauth2/start


Regards,
Rao.

View solution in original post

smanna
Occasional Visitor

Re: oauth 1.0 support

On SOAPUI 5.2.1 there is no OAuth 1.0 authorization available only OAuth 2.0 is available but the twitter project available under sample projects shows the Authorization for OAuth 1.0 also any apps created on twitter gives OAuth 1.0 creds. consisting of access Token and secret, is there any way that we can downgrade to OAuth 1.0 on SOAPUI.

Since many apps are still using OAuth 1.0 can there be an option to have OAuth 1.0 also along with OAuth 2.0 ?

Reason: Every-time we try to connect to Twitter API endpoints with the Credentials given by Twitter it fails and the reason looks like the mismatch in the authorization version and the verification mechanism employed by the different techniques.

cancel
Showing results for 
Search instead for 
Did you mean: