Ask a Question

Unable to srat ReadyApi on GlobalProtect VPN on macOs Big Sur 11.6

4eprasov
New Contributor

Unable to srat ReadyApi on GlobalProtect VPN on macOs Big Sur 11.6

Hello.

I'm having an issue starting ReadyApi when my VPN is ON.

If I disable the VPN app starts with no issues, but I need a VPN to get my floating license from our server.

Error log:
Jan 20, 2022 12:39:48 PM com.sun.javafx.application.PlatformImpl startup
WARNING: Unsupported JavaFX configuration: classes were loaded from 'unnamed module @7e5c856f'
Missing action [LoadUINGAction]
Missing action [MonitorApisAction]
Missing action [LoadUINGAction]
Exception in thread "Thread-14" java.util.ConcurrentModificationException
at java.base/java.util.HashMap$Ha**bleep**erator.nextNode(HashMap.java:1584)
at java.base/java.util.HashMap$KeyIterator.next(HashMap.java:1607)
at com.smartbear.ready.util.ReadyTools$1.run(ReadyTools.java:81)
at java.base/java.lang.Thread.run(Thread.java:831)
Thanks 

3 REPLIES 3
richie
Community Hero

Hey @4eprasov 

 

To be clear - what happens to ReadyAPI! when you start your VPN?  Does ReadyAPI freeze? 

 

I've seen this error in my logging way back on a particular version (I cant remember what), but it didnt actually visibly impact the running of ReadyAPI at all (but mine was on Windows) and I dont currently have a MacOS instance of ReadyAPI so I cant replicate.

 

Whats the sequence of events when you see this error in the logging - have you already got ReadyAPI started and THEN launch the VPN?  what happens if you've already got the VPN running and then start ReadyAPI!?

 

Have any of  your colleagues seen this behaviour?

 

Cheers,

 

Rich

if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the Subject header field of the post to something more descriptive? This will help people when searching for problems. Ta

Hi, Rich thanks for your reply.

I'm getting failed to start ReadyApi when my VPN is ON with the error message and the app closed by itself with no other errors on the screen.

If I disable VPN - ReadyApi starts with no issues. Then I trigger VPN back on to get the license from our local server.

Most of our team uses windows laptops and they don't have this issue.

Thanks

sonya_m
SmartBear Alumni (Retired)

Thank you Rich!

 

Hi @4eprasov, I would suggest showing this issue to the ReadyAPI support team


Sonya Mihaljova
Community and Education Specialist

cancel
Showing results for 
Search instead for 
Did you mean: