Ask a Question

SoapUI NG Pro Jenkins integration issue - Import License

NandorRigo
Frequent Visitor

SoapUI NG Pro Jenkins integration issue - Import License

Hi, 

 

We are using the 1.4.0 version of Ready API with SoapUI NG Pro. We have floating licenses for our machines and for Continuous integration as well.

 

The old test jobs use the old 5.0.0 SoapUI Pro Maven plugin, but for a new project, we wanted to use the latest version, since the licenses apply to the NG Pro as well.

 

The problem came, when I've tried to use the latest Maven plugin for the Jenkins job. The job fails with the following:

 

00:48:14,170 INFO  [DefaultSoapUICore] All plugins loaded
No valid SoapUI NG license exists.
Do you want to install a license? [y/N]: [ERROR] java.util.NoSuchElementException

...

[ERROR] Failed to execute goal com.smartbear:ready-api-maven-plugin:1.4.0:test (default-cli) on project shpm-soapui-project: Ready! API Test(s) failed -> [Help 1]
org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute goal com.smartbear:ready-api-maven-plugin:1.4.0:test (default-cli) on project shpm-soapui-project: Ready! API Test(s) failed
	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:212)
...
Caused by: org.apache.maven.plugin.MojoFailureException: Ready! API Test(s) failed

My managers assured me, that the "old" SoapUI Pro licenses have to work until the end of this year. There is proof for that, since the old jobs are running just fine.

 

My question: Is the old SoapUI Pro floating license for Jenkins valid for the Ready API and NG Pro integration? Should we buy a new floating license for the NG CI integration?

 

Note: I've searched the forums for solutions, every single thread shows, that I have to update the dependencies to 1.4.0 and the issue is going to be fixed. Did that, nothing helps.

 

Regards, 
Nandor

11 REPLIES 11
nmrao
Community Hero

May be you can try opening a support request.


Regards,
Rao.
tusar
Occasional Contributor

Any update on this query? Even i am facing same issue, raised a support ticket waiting for reply from smartbear.

rka
Occasional Contributor

same problem on my side.

 

bought a licence, but how to get it a easy way to jenkins/linux?

we'd like to run our tests with java/junit

 

also opened a support ticket

rka
Occasional Contributor

The support team answered :

 

You can download ‘Ready! API license manger’ from: https://support.smartbear.com/downloads/readyapi/
It’s a command line utility to activate licenses on a headless machine.
java -jar ready-api-license-manager-1.0.jar -i
You need to have a JRE 7 or later installed on the machine, to be able to run the jar included in the zip file.

 

Seems to be good and easy solution! When startet, it looks like this:

>> java -jar lib\ready-api-license-manager-1.0.jar -i
Please select the tool for which license info should be printed
1. SoapUI NG
2. LoadUI NG
3. Secure
4. ServiceV
5. VirtServer
6. Ready! API TestServer

 

 

tusar
Occasional Contributor

I followed the same, now it works.

rka
Occasional Contributor

unfortunatelly it's still not working on our side

now we could create the licence with the jenkins user

also a '/var/lib/jenkins/.soapui' has been created

but when we run tests, we still get "No valid SoapUI NG license exists." 

tusar
Occasional Contributor

i did following way:

 

1. Ran the soap ui -> testrunner

2. Entered license info in comand line, activation was successful and my test suite started executing.

 

 

rka
Occasional Contributor

Hi tusar

thanks for helping

but actually we have not installed soapui directly on jenkins machine

because we use Java/JUnit, all required SoapUI JAR files are beeing deployed to the jenkins machine

therefore we'd like to activate the licence without an additional installing of the soapui software

 

Currently we are trying with providing parameters :

-Duser.home=/var/lib/jenkins -Dsoapui.home='/var/lib/jenkins/.soapui'

 

but it doesn't work yet

tusar
Occasional Contributor

As i understand, you are trying to run soap UI testsuites in jenkins machine, obviously you need an activate license over there(jenkins). what is your expectation?
cancel
Showing results for 
Search instead for 
Did you mean: