Ask a Question

Help - JMS setup ActiveMQ - "JNDI name was not found"

Frequent Contributor

Help - JMS setup ActiveMQ - "JNDI name was not found"


I have a frustrating issue with the setup of a JMS connection via ReadyAPI v2.8.2.

Goal is to go and get all messages in the queue ""


ActiveMq =


I followed the full procedure as mentioned here:

1) Created a JMS connector plugin (library files activemq-all-5.15.9) & installed it

2)  Setup JMS configuration with the additional JNDI properties

3) Created an endpoint, edited it to make it a readyjms protocol according to the requested format = <protocol>://<server/session>::<send/publish destination>::<receive/subscribe destination>  

----> readyjms://activemq::-::get  ( )

Of this last step I'm not quite sure I did it right. The documentation says:"Select the method for which you want to create a JMS request and click OK." How does this service relate to the activeMq queue? I cannot create a service that starts with readyjms:// as that's not valid. I just created a "dummy" http value, the one I see when I go to the activeMq page (http://urltomyactivemq) and then edited the endpoint.


So, now every time I send a request for the JMS step I get: 

Error getting manually configured JMS connection - javax.naming.NameNotFoundException: get
CannotResolveJmsTypeException: The JNDI name was not found: get. Make sure the specified name is correct and additional JNDI properties are specified.

I tried to change the name a zillion times in both the endpoint and the JMS configuration but always the same.

Tried to remove the 'queue.' in the additional properties name, tried setting the name exactly the same as the queue name, tried to add another queue to get both send and receive,... no difference.

When I set both send & receive destionations to "-" there is no error and the logs show: Got response for [http://urltomyactivemq] in 64ms (0 bytes). So even when my config would be fine, why does he still go to the "dummy" http endpoint?


It's my first JMS-step try, so perhaps I'm doing something (obvious) wrong. 



Frequent Contributor

Ok... seems like I found the answer myself...

As a last resort I tried to setup the JMS server name with lowercases in both configuration and endpoint... That seemed to do the trick! 




Never knew ReadyApi was so case sensitive for configuration settings, moreover because (the pictures provided in the) documentation does not seem be in line with this.

SmartBear Alumni (Retired)

Great to hear that you have found a solution, @JoostDG! And thank you for sharing it with the Community!


I will mark it as a Solution.

Have a great day!

Olga Terentieva
SmartBear Assistant Community Manager

Showing results for 
Search instead for 
Did you mean: