Ask a Question

Error in JDBc connection

SOLVED
aktrip
New Contributor

Error in JDBc connection

Hi,

I am using Ready API 3.20  and while setting up jdbc connection, getting error:

"Cannot get a connection for the specified properties com.microsoft.sqlserver.jdbc.SQLServerException: This driver is not configured for integrated authentication. ClientConnectionId:04e02315-0fe8-4d0e-9da3-4d9ca1553bee"

 

Have all necessary files in \bin and \ext folders

under program Files\smartbear\ReadyAPI-3.20.0\bin file mssql-jdbc_auth-9.4.1.x64.dll exist

under program Files\smartbear\ReadyAPI-3.20.0\bin\ext file mssql-jdbc-9.4.1.jre16.jar exist

 

 

3 REPLIES 3
richie
Community Hero

Hey @aktrip 

 

 

You're using mixed mode auth - so you've got the right idea -  you need both the .jar and the auth .dll - and as long as the config on the server isn't problematic you should be fine (I've found configuring SQLServer connections for ReadyAPI a little fiddly sometimes and I've had to play with the config settings on the server end - but that was a couple of years ago.

 

 

Ok - so this is either a problem with your Connection string/URL or the JDBC driver versions you have. 

 

Have you confirmed you have the correct Connection URL setup (with all required parameters)?

 

Have you confirmed you have the correct driver versions for the version of SQLServer you want to connect to?

 

Cheers,

 

Rich

 

 

if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the Subject header field of the post to something more descriptive? This will help people when searching for problems. Ta
aktrip
New Contributor

Hi,

Thanks for your reply. I m using ready API 3.20 and took the correct version of dll and JAr files (mssql-jdbc-9.4.1.jre16.jar and mssql-jdbc_auth-9.4.1.x64.dll)

Copied them Bin and ext folders.

and I have confirmed that driver version is also correct.

Still im getting same error.

aktrip
New Contributor

@richie 

Thanks so much for your advise. I was using incorrrect version of dll and jar files

used 9.4.0 version and able to connect successfully. 🙂

cancel
Showing results for 
Search instead for 
Did you mean: