Ask a Question

Error getting response; java.lang.StackOverflowError

New Contributor

Error getting response; java.lang.StackOverflowError

I have been using SoapUI 4.6.4 for a couple of years. All the sudden it got an error "Error getting response; java.lang.Exeption: java.lang.StackOverflowError" when I run my soap request. This error appears at the bottom of the screen. The error log did not give me any good clue. Below are a couple of lines from the error log.
at Source)
at com.eviware.soapui.impl.wsdl.submit.transports.http.HttpClientRequestTransport.sendRequest(

I installed SopaUI 5.0.0 to run my soap request. I still have the same issue. So this tells me that it is not a SoapUI issue but java issue. However I don't know exactly what is the root cause yet. If anyone had the same issue and solution I would really appreciate it, if you can share. In the mean time I will keep on researching.
New Contributor

Here is more information that I did to troubleshoot. I increased the java run time memory and still have the same issue. I downloaded SoapUI Pro version 5.1.2. It is working fine for me. So this rules out java issue. Other developer in my team do not have any issue with their SoapUI 4.6.4. I still need to solve this issue.
New Contributor

OK, I found the solution. JVM was running out of memory. I had to set the stack memory size to 512m. To do so, go to C:\Program Files (x86)\SmartBear\SoapUI-4.6.4\bin. Edit soapui.bat file to have JAVA_OPTS line looks like mine below. Restart the SoapUI. I got no more StackOverflowerror. Woo took me a while to figure out but I am glad I did.
set JAVA_OPTS=-xms512m -Xms256m -Xmx2048m "-Dsoapui.home=%SOAPUI_HOME%\" -splash:soapui-splash.png
Occasional Contributor

Hello mates,

I have changed my JAVA_OPT in SOAPUi5.4.0/bin and my looks like below:

set JAVA_OPTS=-xms512m -Xms256m -Xmx2048m -XX:MinHeapFreeRatio=20 -XX:MaxHeapFreeRatio=40 "-Dsoapui.home=%SOAPUI_HOME%\" -splash:SoapUI-Spashscreen.png


But it still not working - Something wrong?




@Remy_Fale: You are replying to a thread that is 4 years old. You may want to consider starting a new post and giving your specific details. Thanks!


Click the Accept as Solution button if my answer has helped, and remember to give kudos where appropriate too!
Occasional Contributor

I know but what’s the difference if i do have the same issue and the description corresponds to mine?
Although I Will consider your proposition if Ido not get an answer👍🏾.



I think is not bad thing replying to a thread that is 4 years old. Because this is a big issue. I need to use OAuth2 with my wifi which have a proxy. And I have try all solutions that tell in Internet but with another versions below of 5.4.0 to what I have, and they don't work.


Please we need a solution.


The error on page is: "The page could not be loaded" I have tested with proxy and without and unsuccessfull. Cause with a wifi without proxy it works.


Please help 🙂

Showing results for 
Search instead for 
Did you mean: