cancel
Showing results for 
Search instead for 
Did you mean: 

Automated test in QAComplete stuck "In Queue"

SOLVED
Occasional Contributor

Automated test in QAComplete stuck "In Queue"

We have two Test Host VMs available in QAComplete to run our TestComplete tests. 

TestHost1 is working fine (Run test in QAC, Test Agent logs in to TestHost1, runs test, provides results in QAC.)  TestHost2 was set up a few months later and we have an issue...  

 

- I can run my tests manually on TestHost2 when I log in as the TestAgent user.

- I can run my tests from QAComplete on TestHost2 *if* I am logged in to that VM as the TestAgent user when I kick off the test in QAC.

- ISSUE:  If I run my tests from QAC on TestHost2 when I am NOT logged in to TestHost2 as TestAgent user, the test never starts.  It remains "In Queue" with the timer running until we click "End Test".  

 

I have verified that the TestComplete service is running on TestHost2.  

TestComplete is on the list to let through the firewall on TestHost2.

I checked the recommended settings in TestComplete on TestHost2 and they appear to be in order.

 

We have this working on TestHost1 and it works on TestHost2 under some conditions, so I feel like I am missing something obvious.  

 

Any ideas?

1 ACCEPTED SOLUTION

Accepted Solutions
Occasional Contributor

Re: Automated test in QAComplete stuck "In Queue"

The culprit was Group Policy settings on the VM.  

 

This setting in particular: 

the Require use of specific security layer for remote (RDP) connections group policy is enabled on it and the security layer is set to Negotiate.

 

SmartBear Support was instrumental in finding this.  They instructed us on how to create and capture many logs (installation logs, system logs, etc.)  I recommended that they add logging information to the product documentation.

View solution in original post

3 REPLIES 3
Occasional Contributor

Re: Automated test in QAComplete stuck "In Queue"

Are they any logs created regarding TestHost access from QAC?  I need clues!

Occasional Contributor

Re: Automated test in QAComplete stuck "In Queue"

I did find a way to generate the TestAgent logs (advanced settings in the Test Agent Settings app.) 

 

A taService_212.log file is not created unless I am logged in on the TestHost as the designated TestAgent user.   When a taService_212.log file is not created, the test does not run.  That is what I know so far.

Occasional Contributor

Re: Automated test in QAComplete stuck "In Queue"

The culprit was Group Policy settings on the VM.  

 

This setting in particular: 

the Require use of specific security layer for remote (RDP) connections group policy is enabled on it and the security layer is set to Negotiate.

 

SmartBear Support was instrumental in finding this.  They instructed us on how to create and capture many logs (installation logs, system logs, etc.)  I recommended that they add logging information to the product documentation.

View solution in original post

New Here?
Join us and watch the welcome video:
Watch the new Interview