cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to upload Scenario to Agent

SOLVED
Highlighted
Occasional Contributor

Unable to upload Scenario to Agent

I have ReadyAPI 2.7.0 on my laptop (Ubuntu) and a LoadUI Agent running on virtual machine (CentOS). When I try to run my load test, I get the following message:

 

"Unable to start the load test, because the "Scenario 1" scenario has not been uploaded to the "Agent 1" agent. Please try to run the test later."

 

I have SSHed to the virtual machine and made sure the LoadUI Agent is running. I can run the load test on my local computer no problem. The Agent is definitely connected, CPU and Memory usage are currently 0% (though they've been as high as 40% as I was troubleshooting).

 

Why is this happening and how can I fix it? Any help is appreciated.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Occasional Contributor

Re: Unable to upload Scenario to Agent

The LoadUI agent was crashing in the background. Killing and restarting it fixed the problem after the umpteenth time.

View solution in original post

1 REPLY 1
Highlighted
Occasional Contributor

Re: Unable to upload Scenario to Agent

The LoadUI agent was crashing in the background. Killing and restarting it fixed the problem after the umpteenth time.

View solution in original post

New Here?
Join us and watch the welcome video:
Announcements
Script Wanted
Let's start July with new challenges!

Create a script to change request body before sending it to the server for the TechCorner tag!


Scripts created in June:
- A script to generate a request body based on data from Datasource
- A script to go through all response nodes and check the value of the required field
- A Dispatching script to get responses based on the values in Request Body
- A script to add a new tag and assign it to all TestCases in a TestSuite