Ask a Question

Load testing fails due to IFRAME usage

ramdan2066
Occasional Visitor

Load testing fails due to IFRAME usage

We have a vendor that supplies us the content.  They use IFRAMES and JavaScript and every few seconds that IFRAME takes focus, runs an authentication, and then goes back to the background.  Not an issue for our users.

 

However, with LoadNinja, about 30% of the time it conflicts with whatever LoadNinja is doing in the VU, the IFRAME can not get focus and we lose the authentication and get a time-out.  We did several tests and similar results.  This also explains why our JMETER scripts have the same issue with time-outs, 

 

Errors:

Error: the string "no such frame\n  (Session info: headless chrome=96.0.4664.45)\n  (Driver info: chromedriver=96.0.4664.45 (76e4c1bb2ab4671b8beba3444e61c0f17584b2fc-refs/branch-heads/4664@{#947}),platform=Linux 4.14.252-195.483.amzn2.x86_64 x86_64)" was thrown, throw an Error 🙂

 

 

22, 3:32:54 PM

deprecation

warning

Synchronous XMLHttpRequest on the main thread is deprecated because of its detrimental effects to the end user's experience. For more help, check https://xhr.spec.whatwg.org/.

https://www.xsomesite.com//XmlHttp.js?dtm=5248221292107387904

-

{"callFrames":[{"functionName":"PostXmlHttpRequest","scriptId":"72","url":https://www.xsomesite.com//XmlHttp.js?dtm=5248221292107387904,"lineNumber":0,"columnNumber":2819},{"functionName":"fatalAttemptRestart","scriptId":"61","url":https://www.xsomesite.com//FramesetSkin.js?dtm=5249258264307387904,"lineNumber":0,"columnNumber":9970},{"functionName":"fatalConfirm","scriptId":"61","url":https://www.xsomesite.com//FramesetSkin.js?dtm=5249258264307387904,"lineNumber":0,"columnNumber":10500},{"functionName":"fatalSystemErrorProcessing","scriptId":"61","url":https://www.xsomesite.com//FramesetSkin.js?dtm=5249258264307387904,"lineNumber":0,"columnNumber":11348},{"functionName":"fatalSystemError","scriptId":"61","url":https://www.xsomesite.com//FramesetSkin.js?dtm=5249258264307387904,"lineNumber":0,"columnNumber":12449},{"functionName":"tick","scriptId":"61","url":https://www.xsomesite.com//FramesetSkin.js?dtm=5249258264307387904,"lineNumber":0,"columnNumber":37877},{"functionName":"","scriptId":"61","url":https://www.xsomesite.com//FramesetSkin.js?dtm=5249258264307387904,"lineNumber":0,"columnNumber":151252}]}

-

 

 

 

 

 

1 REPLY 1
Tom_S
Staff

Hi ramdan2066,

 

I would like to be able to check this issue with our developers. In case you still face the same issue you can create a support case to report the load test or script where you face this issue.

 

https://support.smartbear.com/loadninja/message/

 

Greetings,

Tom

LoadNinja Customer Care
cancel
Showing results for 
Search instead for 
Did you mean: