cancel
Showing results for 
Search instead for 
Did you mean: 

Data is not created in the application after load test run?

Occasional Contributor

Data is not created in the application after load test run?

Hi,

I am new to loadcomplete. The application is running on Salesforce and is web base. I use the keyword test recording the following steps in TestComplete 12.50, then create the load test from TestComplete. It is a simple test:

1. Login

2. Add new business, enter the field in the form and save.

3. Logout

I run the load test and it show result Sucess in green.

I login to my Salesforce application, i don't see the new business created. Anyone can help?

I run just 1 virtual user to test out. 

Blessings

Ling

2 REPLIES
New Member

Re: Data is not created in the application after load test run?

Lots of issues will occur while using a printer to print your own idea to present every presentation or
documents. If you are using canon printer and getting an issue with this so Canon Printer Support is here
to give instant help to the user who gets any troubles.

Highlighted
Community Hero

Re: Data is not created in the application after load test run?

Hi Ling,

 

My first guess is that test in TestComplete works fine and adds new businesss as expected.

If the above is correct, then you should carefully examine the test in LoadComplete. First of all you must identify request(s) that perform login operation and ensure that your virtual user was indeed gratned access to the application. You are writing that the whole test in LoadComplete is marked as passed (green). This makes me think that either login sequence works correctly and as expected or no error is raized in the tested application in case of invalid login and the application just navigates to some default page. You should check this first. To do this, go through the test log and check that simulated request(s) match recorded one(s) (consider applied data correlation) and that returned responses also logically match those that were recorded.

 

After you make login sequence work in LoadComplete test, you must follow the same procedure for the new business creation sequence: identify request(s) that is/are responsible for this operation and verify that correct data (including cookies and/or other identifiers both in the request headers and bodies) are used.

 

In order to get more detailed reply, consider to post here your LoadComplete test project. If for some reason you are not allowed to do this, you may contact me via the private messaging and I will try to take a look at your project and let you know my findings and considerations.

 

Regards,
Alex
[Community Expert Group]
____
[Community Expert Group] members are not employed by SmartBear Software but
are just volunteers who have some experience with the tools by SmartBear Software
and a desire to help others. Postings made by [Community Expert Group] members
may differ from the official policies of SmartBear Software and should be treated
as the own private opinion of their authors and under no circumstances as an
official answer from SmartBear Software.
[Community Expert Group] signature is used with permission by SmartBear Software.
http://smartbear.com/forums/f83/t86934/community-experts/
================================
Are You In?

Meet the Community Leaders!

SmartBear Connect is an excellent opportunity for training, in-person support, and networking.

GET YOUR TICKET WITH $100 OFF