cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to add files for review using P4 plugin

SOLVED
New Contributor

Unable to add files for review using P4 plugin

I've recently set up my mac for code reviewing using p4v for file syncing/ changelists and ccollab for the review platform. Versions are:

MacOS - 10.15.7

Perforce - P4V/MACOSX1015X86_64/2020.1/1966006

ccollab client - 13_1_13100

 

Via the coollabgui app, I have the SCM verified and connected with no errors. I am unable to add pending changelists for review, but I can add submitted changelists. What's more is I'm able to submit files for review by manually uploading them through the web client. The big headache comes when I attempt to use the smartbear custom tool that installation builds into P4V. Attempting to right-click and add any changelist results in the following error:

 

No SCM Configuration could be determined

Cannot run program "p4" (in directory "/Applications/ccollab_client/ccollabgui.app"): error=2, No such file or director

 

I have reviewed the following other topics and found no solutions:
https://community.smartbear.com/t5/Collaborator/quot-No-SCM-could-be-determined-quot-p4-plugin-does-...

https://community.smartbear.com/t5/Collaborator/Config-p4-plugin-on-Mac/m-p/44317

 

Any ideas? It's looking like this could be a potential bug.

1 ACCEPTED SOLUTION

Accepted Solutions
Staff

Re: Unable to add files for review using P4 plugin

Hello @Elbrowz,

 

This issue usually occurs in the system where the Perforce command-line client (p4) is not added to the environment path. Try to follow the steps below:

1. In the P4v client, select "Tools | Manage custom Tools | SmartBear - Add to Review" and click "Edit".
2. In the "Arguments" field, add the "--p4 your_current_path_to_p4" option after "--scm perforce".
Note: Don't change any other options.
3. Click "OK", restart the P4v client, and try to reproduce the issue.

 

If the issue still persists after following the steps above, ensure that the path to the "ccollabgui" file in the "Application" field of the "Edit Custom Tool" menu is correct, too. 


 

Regards,
Oleg Beriashvili
Technical Support Engineer

View solution in original post

2 REPLIES 2
Staff

Re: Unable to add files for review using P4 plugin

Hello @Elbrowz,

 

This issue usually occurs in the system where the Perforce command-line client (p4) is not added to the environment path. Try to follow the steps below:

1. In the P4v client, select "Tools | Manage custom Tools | SmartBear - Add to Review" and click "Edit".
2. In the "Arguments" field, add the "--p4 your_current_path_to_p4" option after "--scm perforce".
Note: Don't change any other options.
3. Click "OK", restart the P4v client, and try to reproduce the issue.

 

If the issue still persists after following the steps above, ensure that the path to the "ccollabgui" file in the "Application" field of the "Edit Custom Tool" menu is correct, too. 


 

Regards,
Oleg Beriashvili
Technical Support Engineer

View solution in original post

New Contributor

Re: Unable to add files for review using P4 plugin

And just like that, weeks of work is now done! Thanks so much 🙂

New Here?
Join us and watch the welcome video:
Announcements