cancel
Showing results for 
Search instead for 
Did you mean: 

hermes-config.xml not working with Ready API 1.2.2 SoaPUI PRO

SOLVED
Highlighted
Occasional Contributor

hermes-config.xml not working with Ready API 1.2.2 SoaPUI PRO

I recently installed Ready API 1.2.2 and got a SoapUI NG PRO license. I am trying to use the hermes-config.xml I used with SoapUI 5.0.0 (where it worked perfectly) but it doesn't work.

I can start HermesJMS from SoapUI NG and view the configuration.

Adding a JMS Endpoint however does NOT work.

Could you please help me along?

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Moderator

Re: hermes-config.xml not working with Ready API 1.2.2 SoaPUI PRO

This is fixed in Ready API 1.4.  Until Ready API 1.4 is released please use the workaround below.

 

Download cglib-2.2.jar from http://sourceforge.net/projects/cglib/files/cglib2/2.2/and put it to
{Ready API install}/hermesJMS/lib folder. After that is done restart Ready API.


Regards,
Marcus

SmartBear Support



Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️

View solution in original post

19 REPLIES 19
Highlighted
Community Hero

Re: hermes-config.xml not working with Ready API 1.2.2 SoaPUI PRO

Have you tried with the same hermes-config.xml which worked in 5.0.0?

By that way, do you see anything in the logs?


Regards,
Rao.
Highlighted
Occasional Contributor

Re: hermes-config.xml not working with Ready API 1.2.2 SoaPUI PRO

I used the exact same hermes-config.xml which worked in 5.0.0!

I can't find any logging. HermesJMS logs to C:\Program Files\SmartBear\ReadyAPI-1.2.2\bin\null! ???

Is there a way to change that?

 

Jens

Highlighted
Occasional Contributor

Re: hermes-config.xml not working with Ready API 1.2.2 SoaPUI PRO

Ok, so I followed the steps from tutorial http://www.soapui.org/JMS/getting-started.html to add an activeMQ session. This works fine. The session is showing in the Add JMS endpoint dialog. This session is configured in the same hermes-config.xml as my TIBCO EMS session (which is not showing in the dialog). Could it be there is something wrong with the JAR's I am using?

 

These are the JAR's:

com.tibco.tibjms.custom.customobjectfactory_1.0.0.jar
jms.jar
slf4j-api-1.4.2.jar
slf4j-simple-1.4.2.jar
tibcrypt.jar
tibemsd_sec.jar
tibjms.jar
tibjmsadmin.jar
tibjmsapps.jar
tibjmsufo.jar
tibrvjms.jar

 

Found the hermes.log by the way... 🙂

Is there a way to add the logfile to a post?

Highlighted
Occasional Contributor

Re: hermes-config.xml not working with Ready API 1.2.2 SoaPUI PRO

Right,

 

Been playing around with the session settings...

Seems that when I choose class hermes.NullConnectionFactory in the Connection Factory field in HermesJMS, the session suddenly appears in the Add JMS endpoint dialog in Ready API...

Any clue as to what is going wrong here?

 

Jens

Community Hero

Re: hermes-config.xml not working with Ready API 1.2.2 SoaPUI PRO

If you use 'Reply' button, files can be attached.



Regards,
Rao.
Highlighted
Community Hero

Re: hermes-config.xml not working with Ready API 1.2.2 SoaPUI PRO

Have you happened to see the links below? See if that resolves your issue?

  1. http://tibcoadmin.com/tibco/ems/configuring-hermesjms-for-tibco-ems/
  2. http://stackoverflow.com/questions/24259762/hermesjms-and-tibco


Regards,
Rao.
Highlighted
Occasional Contributor

Re: hermes-config.xml not working with Ready API 1.2.2 SoaPUI PRO

Rao,

 

I have seen both links before, but when I select the com.tibco.tibjms.TibjmsConnectionFactory class in the Connection Factory canvas, the session does not show in the Add JMS endpoint dialog anymore.

 

Jens

Highlighted
Occasional Contributor

Re: hermes-config.xml not working with Ready API 1.2.2 SoaPUI PRO

Next thing...

 

I downloaded cgilib-2.2.2.jar and put it in the hermesJMS\lib folder.

Now I can actually see the JMS session in the Add JMS endpoint dialog in ReadyAPI.

The error I now get is:

 

2015-04-10 17:19:54,838 ERROR [SoapUI] An error occurred [Failed to connect to the server at tcp://localhost:7222], see error log for details

 

I have configured the remote EMS-server url in the Plug In canvas as well as the Connection Factory canvas.

 

Any ideas?

 

Jens

Highlighted
Community Hero

Re: hermes-config.xml not working with Ready API 1.2.2 SoaPUI PRO

Can you try removing existing file %SOAPUI_HOME%\lib\hermes*.jar(have backup) and copying %HERMES_HOME%\lib\hermes.jar there and see?


Regards,
Rao.
New Here?
Join us and watch the welcome video:
Announcements
Top Kudoed Authors