Showing results for 
Search instead for 
Did you mean: 

WSS Encryption not working

Occasional Contributor

WSS Encryption not working

I have tried countless combinations when trying to setup Encryption. I guess what I need to know from Soapui is:

1. How can I encrypt the whole message
2. How can I encrypt part of the message






< See image for parms set >

Trying to encrypt whole message

When following instructions to encrypt the whole message (leaving "Parts:" empty), I get the following error: ERROR:java.lang.NullPointerException

When Checking off "Create Encypted Key" I get no errors at all. The message doesn't even make it to the destination.

(See bottom of image)

Trying to encrypt parts of the message

When trying to encrypt just a Part of the message, I get this error no matter how I reference the Name in "Parts:"

Just always seems to have nullpointer execption on the "error.log" when I use the encryption method. 

I have checked out the documentation and not much there to help, also search the forum and tried the following and still got the following error.

did not work
1) Add your keystore/public-key to your projects' WS-Security tab
2) Add a new outgoing WSS configuration
3) Add an Encryption item to this configuration and configure it accordingly
4) Set your request to use the created Outgoing WSS configuration (either in the AUT inspector, Request Properties or Service Endpoint defaults).

I am using the latest Pro Beta version available from the site.

Below is the error log exception that is being raised

Wed Dec 17 14:54:32 CST 2008:ERROR:java.lang.NullPointerException
  at com.eviware.soapui.impl.wsdl.submit.filters.WssRequestFilter.filterWsdlRequest(
  at com.eviware.soapui.impl.wsdl.submit.filters.AbstractRequestFilter.filterAbstractHttpRequest(
  at com.eviware.soapui.impl.wsdl.submit.filters.AbstractRequestFilter.filterRequest(
  at com.eviware.soapui.impl.wsdl.submit.transports.http.HttpClientRequestTransport.sendRequest(
  at java.util.concurrent.Executors$ Source)
  at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
  at Source)
  at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
  at java.util.concurrent.ThreadPoolExecutor$ Source)
  at Source)
Occasional Contributor

Re: WSS Encryption not working

I think I got it figured out, so I should be good for now.

FYI.. I did try the same thing on the non pro version 2.5 and it still is throwing the null pointer exception.  Not sure of difference.
Super Contributor

Re: WSS Encryption not working

Hi Mark,

thanks for your feedback.. Are you saying that a working config in soapUI Pro got you a NPE in open-source?


New Here?
Join us and watch the welcome video:
Top Kudoed Authors