cancel
Showing results for 
Search instead for 
Did you mean: 

Very slow when switch between test steps in ReadyAPI after convert to composite project

SOLVED
Highlighted
New Contributor

Very slow when switch between test steps in ReadyAPI after convert to composite project

 

We have just started with ReadyAPI and added only 4 sample requests/steps in a new project. It work well at the beginning, but when I tried to convert it to the composite project and integration with the Devops repo, switch between steps/folders became very slow, which need several seconds(around 5 seconds for switch to another test step). As there is only 4 requests here, it shouldn't be that slow and make it very annoying. Is there any thing I need to config to avoid this situation? thanks.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Community Hero

Re: Very slow when switch between test steps in ReadyAPI after convert to composite project

Hey @Chen-CPA,

If your resourcing isnt a problem then i think id convert my composite file back to flat .xml then back again.

Id be curious if the behaviour disappears and then appears over time again.

Other option is that depending on the above test, i might submit a support ticket to smartbear

Rich

if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the Subject header field of the post to something more descriptive? This will help people when searching for problems. Ta

View solution in original post

3 REPLIES 3
Highlighted
Community Hero

Re: Very slow when switch between test steps in ReadyAPI after convert to composite project

Hey @Chen-CPA 

 

have a look at the following links to optimise your resourcing 

 

link1

link2

link3

 

cheers,

 

rich

if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the Subject header field of the post to something more descriptive? This will help people when searching for problems. Ta
Highlighted
New Contributor

Re: Very slow when switch between test steps in ReadyAPI after convert to composite project

 
 

Hi Rich,

 

Thanks for your reply.

 

I don't think this is related to the memory usage, but I have tried your suggestion any way. But it doesn't work. I have changed the config to -Xmx16384m, which is as suggested in the article as half of my memory, and restarted the app, but nothing changed. I have also monitor the usage of ReadyAPI, which is as low as only 800-900MB. As I mentioned in the post, there are only four requests/steps in current project, which is just as a sample project at the moment, without any complex assertion or scripts. Do you have any other suggestion? thanks.

 

Regards,

Chen

Highlighted
Community Hero

Re: Very slow when switch between test steps in ReadyAPI after convert to composite project

Hey @Chen-CPA,

If your resourcing isnt a problem then i think id convert my composite file back to flat .xml then back again.

Id be curious if the behaviour disappears and then appears over time again.

Other option is that depending on the above test, i might submit a support ticket to smartbear

Rich

if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the Subject header field of the post to something more descriptive? This will help people when searching for problems. Ta

View solution in original post

New Here?
Join us and watch the welcome video:
Announcements
Top Kudoed Authors