cancel
Showing results for 
Search instead for 
Did you mean: 

Support for Russian Characters

mbroadbe42
New Contributor

Support for Russian Characters

Hi,

 

When I try and get Russian Characters from a Rest call they appear as ??? in Ready API 1.8/SoapUI NG. I saw one post indicating to change the Encoding to UTF-8, but that didn't help. I saw another indicating to change the display to Native look, but in the Preferences->UI section there no longer appears to be that option.

 

What is the current methodology for fixing this issue?

 

Thanks,

Michael

5 REPLIES 5
TanyaYatskovska
Community Manager

Re: Support for Russian Characters

Hi Michael,

 

Does it help if you set Russian in local language settings?

 

In most Windows versions, the steps should be as follows:

  1. Open Region and Language by clicking the Start button, clicking Control Panel, clicking Clock, Language, and Region, and then clicking Region and Language.
  2. Click the Keyboards and Languages 
  3. Under Display language, choose a language from the list, and then click OK.
---------
Tanya Yatskovskaya
SmartBear Community and Education Manager

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️
mbroadbe42
New Contributor

Re: Support for Russian Characters

I haven't tried.

 

I shouldn't have to fully localize the machine from what I gather. I'm testing internationalization which is just the characters themselves. From other posts it seemed like this was possible, but it seems like the settings have moved about a bit.

 

Thanks though,

Michael

nmrao
Community Hero

Re: Support for Russian Characters

Would you please go thru below thread, hope that helps.

https://community.smartbear.com/t5/SoapUI-NG/Chinese-Standard-Characters/m-p/41293/highlight/true#M2...


Regards,
Rao.
mbroadbe42
New Contributor

Re: Support for Russian Characters

Yep thanks, that was the thread I looked at previously.

 

Where is the Native Look option now? I don't see it under the UI tab in Ready 1.8

 

Thanks,

Michael

nmrao
Community Hero

Re: Support for Russian Characters

Unfortunately that was removed. However, you may tweak it using soapui-settings.xml file.

You can see the workaround mentioned in the same thread.

Open settings file, locate settings. And add below statement and restart.

<con:setting id="UISettings@native-laf">true</con:setting>


Regards,
Rao.
New Here?
Join us and watch the welcome video:
Announcements
Top Kudoed Authors