cancel
Showing results for 
Search instead for 
Did you mean: 

SoapUI Projects - Test Suites - WSDL not keeping the saved password

jrhoades
New Contributor

SoapUI Projects - Test Suites - WSDL not keeping the saved password

I am fairly new to SoapUI and used to use a very older standalone pro version before upgrading to the ReadyAPI 2.4.0 which contained SoapUI. I am now having an issue I never had in the older version. In the WSDLs we use we have Authorization set to NTLM. I have a username, password and domain saved. However, every time I open ReadyAPI freash, and run the test suite, instead of producing the results I expect, our application returns an error for wrong username or password. I don't even have to re-enter the password, if I click on the password field and run the wsdl again, it accepts the password and completes my run. I have tried saving that but as soon as I close ReadyAPI and re-open, then I have the same problem all over again. 

Any ideas what is going on? This was never an issue when I was using the older Soap UI on its own (version 5.1). 

 

Update: What I see is going on when I run my test with the different WSDLs is that it is using the authentication from the first WSDL only. When in fact each WSDL might have a different username and password based on what I am testing and accessing with each. Is there a setting to change that so it checks authentication for each wsdl run?

 

Thanks for the help!

2 REPLIES 2
lakshmiarun
Staff

Re: SoapUI Projects - Test Suites - WSDL not keeping the saved password

Hi,

 

Thank you for your post. You could manage your authorization profiles on the Auth manager(Projects tab). Please check the documentation link below:

 

https://support.smartbear.com/readyapi/docs/projects/requests/auth/manager.html

 

Best,

Lakshmi

-------------Lakshmi

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others.↓↓↓↓↓
jrhoades
New Contributor

Re: SoapUI Projects - Test Suites - WSDL not keeping the saved password

Hi, I found the authorization profiles section you referred to and for all my items being tested changed the authetication to NTLM and all my WSDLs have the authorization within them. I did set up different auth profiles and tried assigning them to those as well. 

 

I still get the error  that the username was incorrect on the wsdl that is using a different username and password. This is because it is still using the username and password from the wsdl run first. Like I said, I changed all the auth profiles to what they should be. There must be something else I am missing here. 


Thanks for the help!

New Here?
Join us and watch the welcome video:
Announcements
Top Kudoed Authors